Forum Xamarin.Forms

TMS-90426: Invalid Swift Support for Xamarin Forms Project for Test flight build

PoojaRawatPoojaRawat INMember ✭✭

Hi,

I am getting "ITMS-90426: Invalid Swift Support - The SwiftSupport folder is missing. Rebuild your app using the current public (GM) version of Xcode and resubmit it." issue for TestFlight build for Xamarin forms Project....I don't know what causing issue....any suggestion & how to fix it?

Answers

  • PoojaRawatPoojaRawat INMember ✭✭

    @LandLu , we are not using any swift library previously we used some but currently we don't have any swift lib in project. we pushing build through appcenter to TestFlight

  • LandLuLandLu Member, Xamarin Team Xamurai

    Please check the version of your project on appcenter you may perhaps consume a previous build there.
    Have you tried to package your project directly without using appcenter?

  • PoojaRawatPoojaRawat INMember ✭✭

    Hii @LandLu I changed build configuration in appcenter from 13 to 12 for iOS, I got ITMS-90428: Invalid Swift Support (The files libswiftCoreAudio.dylib, libswiftCoreGraphics.dylib, libswiftUIKit.dylib, libswiftos.dylib, libswiftDispatch.dylib, libswiftMetal.dylib, libswiftCore.dylib, libswiftFoundation.dylib, libswiftQuartzCore.dylib, libswiftDarwin.dylib, libswiftCoreFoundation.dylib, libswiftObjectiveC.dylib, libswiftCoreImage.dylib, libswiftCoreMedia.dylib, libswiftCoreData.dylib don’t match) in place of the SwiftSupport folder is missing

  • LandLuLandLu Member, Xamarin Team Xamurai

    Do you mean you want to use iOS 12 SDK to compile your project?
    My suggestion is to try to submit your binary from the local environment.
    If this issue only occurs on appcenter, try to seek support following this:
    https://docs.microsoft.com/en-us/appcenter/help

  • PoojaRawatPoojaRawat INMember ✭✭
    edited April 3

    @LandLu Yes , I have changed iOS SDK from 13 to 12 to compile project. I will try alternative ways you have suggested for build once

  • PoojaRawatPoojaRawat INMember ✭✭
    edited April 3

    .

  • LandLuLandLu Member, Xamarin Team Xamurai

    I think it's better to use the latest SDK version. You mentioned that you used some swift libraries previously. Try to check the code on AppCenter. Make sure those libraries have been excluded there.

  • PoojaRawatPoojaRawat INMember ✭✭

    @LandLu ok, Seems like with 12.2 iOS SDK in appcenter configuration build is working fine & getting pushed in TestFlight.
    I see with latest SDK ,why these error is coming.

  • LandLuLandLu Member, Xamarin Team Xamurai

    It seems the ipa includes the wrong version of Swift files in the 'SwiftSupport' folder it creates when you generated it using AppCenter.
    My suggestion is to ask the support of AppCenter. And try to generate this ipa file using native environment.

Sign In or Register to comment.