Forum Xamarin.iOS

“An error occurred while trying to start the Broker...” when pair Visual Studio 2019 on Win10 to Mac

sergtksergtk Member ✭✭
edited March 29 in Xamarin.iOS

When I try to pair Mac with VS 2019 I get the following errors: “An error occurred while trying to start the Broker...”
I tried Visual Studio 2019 16.4.6, then I updated to Visual Studio 2019 16.5.1 and get the same result.
Screenshot:

Some details.
On my Mac I have two empty folders, I guess this is one folder for the versions of the Visual Studio above which I tried.
/Users/sergdev/Library/Caches/Xamarin/XMA/Broker/16.4.000.313
/Users/sergdev/Library/Caches/Xamarin/XMA/Broker/16.5.000.521
For the VS 2017 the corresponding folders on the Mac were not empty.

Everything worked fine while I used VS 2017. The issue I got after update to VS 2019.
I read the thread not for VS 2019: https://forums.xamarin.com/discussion/89373/idb-md5-integrity-check-failure
I tried to reboot Mac and PC, clean caches on Mac and reinstall components. I tried to delete Temp on Windows. It does not help.

There is also new comment in the old thread which is without answer: https://forums.xamarin.com/discussion/comment/407137/#Comment_407137

How to connect from VS to Mac?
Thank you

Tagged:

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    I saw someone faced the same issue as yours:
    https://forums.xamarin.com/discussion/180191/cant-pair-to-mac-from-vs19-win-broker-initialization-exceeded-timeout
    Try to help us collect your logs and I suggest posting threads on the VS for Mac forum.

  • sergtksergtk Member ✭✭

    @LandLu thank you for the link.
    The discussion there is about other error, but looks like also related to the broker.
    Hope that this and that errors will be fixed all together.

    Try to help us collect your logs

    Which logs do you need? How can I share them with you?

    I suggest posting threads on the VS for Mac forum.

    I develop on VS for Windows, I just use Mac to connect my iPhone for testing.
    I don't use VS for Mac.

  • RezaMohamedRezaMohamed USMember ✭✭✭

    hey @sergtk I am the poster of the other thread. I was able to resolve this by updating to the patch that was released today (March 31, 2020, VS 16.5.2). In addition, I had to delete some keys and such which is in my initial troubleshooting step.

  • Hello RezaMohamed! I have the same problem with Visual Studio 2019 for Windows! I can't pair to my mac. "An error ccurred while trying to start the broker". How i get the patch that you mention? the patch is for VS 2019 for Windows? What keys do you delete? Can you be more specific??? Help!

    @RezaMohamed said:
    hey @sergtk I am the poster of the other thread. I was able to resolve this by updating to the patch that was released today (March 31, 2020, VS 16.5.2). In addition, I had to delete some keys and such which is in my initial troubleshooting step.

  • RezaMohamedRezaMohamed USMember ✭✭✭

    @JoseRaulTorresSalguero make sure you update Visual studio to the latest build (march 31, 16.5.2), I am assuming you also updated your Mac, hence the issue. I had to delete the following in my Windows machine as well:

    -Delete %localappdata%\Temp\Xamarin\XMA\IDB.Local

    -Delete hosts.key from %Localappdata%l\Xamarin\MonoTouch

  • @RezaMohamed said:
    @JoseRaulTorresSalguero make sure you update Visual studio to the latest build (march 31, 16.5.2), I am assuming you also updated your Mac, hence the issue. I had to delete the following in my Windows machine as well:

    -Delete %localappdata%\Temp\Xamarin\XMA\IDB.Local

    -Delete hosts.key from %Localappdata%l\Xamarin\MonoTouch

    Hello RezaMohamed!

    I did it! Thanks for your help! Tonight i'm going to sleep better! :-)

    Saludos desde México!

Sign In or Register to comment.