Forum Libraries, Components, and Plugins

Xamarin.Firebase.iOS.MLKit Errors

MarcusLeeMarcusLee Member ✭✭

Hello, this is my first time posting a question on Xamarin Forums so please do bear with me for my mistakes.

I am trying to use the Text OCR in the Xamarin.Firebase.iOS.MLKit NuGet pakckage in my Xamarin.iOS project. However I am coming across this debugging error. Have been stuck for days and would really appreciate any help I can get. I have searched online for many solutions but I cant get it to work. I am working on Windows and debugging with a paired Mac in XCode on my iPhone device. I am able to use the On Device Text OCR for my Xamarin.Android Project and is working fine. I just need it to work on an iOS application.

Steps Taken:
1) Installed the NuGet Package in my iOS Project as well as the dependencies.
2) Added "Firebase.Core.App.Configure()" in the projects AppDelegate.cs
3) Created a Firebase Project and added GoogleService-Info.plist in my project and set its action to Bundle Resource.
~~~~

I am able to Install my mobile application on my iPhone device during debugging but the app opens and closes instantly with an error on the output window.
The output on Xamarin that is causing my app to execute but close instantly is:

Application 'com.companyname.marcus-testapp' terminated.
dyld: Library not loaded: @rpath/FirebaseCore.framework/FirebaseCore
Referenced from: /private/var/containers/Bundle/Application/E89525D5-71EF-4A01-9B58-21D35A83C654/Marcus_TestApp.iOS.app/Marcus_TestApp.iOS
Reason: no suitable image found. Did find:
/private/var/containers/Bundle/Application/E89525D5-71EF-4A01-9B58-21D35A83C654/Marcus_TestApp.iOS.app/Frameworks/FirebaseCore.framework/FirebaseCore: code signature invalid for '/private/var/containers/Bundle/Application/E89525D5-71EF-4A01-9B58-21D35A83C654/Marcus_TestApp.iOS.app/Frameworks/FirebaseCore.framework/FirebaseCore'
/private/var/containers/Bundle/Application/E89525D5-71EF-4A01-9B58-21D35A83C654/Marcus_TestApp.iOS.app/Frameworks/FirebaseCore.framework/FirebaseCore: stat() failed with errno=1

Answers

  • ChrisFouChrisFou Member ✭✭

    Did you solve this as getting the same on a new project

Sign In or Register to comment.