Forum Xamarin.iOS


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

XCode can't find included header files on the Mac

SListSList USMember ✭✭

I am porting a Xamarin.Android app to Xamarin.iOS.
The app has some C++ libraries, so I have installed vcremote on my mini Mac, and synchronised it with Visual Studio on my Windows computer.

I added a base C++ library to the Xamarin.iOS project, and built it from Visual Studio using vcremote - all worked fine.
Next, I added another C++ library that refers to the first one, and tried to build that library - but XCode can't find the header from the first library.

In file included from /Users/SLI/vcremote/C/My/Project/Path/From/Windows/MyFile.cpp:22:
1> /Users/SLI/vcremote/C/My/Project/Path/From/Windows/stdafx.h:10:10: fatal error: 'AnotherPath/MyBaseLibary.h' file not found
1> #include "AnotherPath/MyBaseLibary.h"
1> ^~~~~~~~~~~
1> 1 error generated.

In the project properties, the include directory in Windows for this header file is correctly set. What else must I do to ensure that XCode finds the include path via vcremote?

vcremote Version = 1.0.16
xcode Version = 11.3.1
Mac OS Version = Catalina
Visual Studio Version = 16.4.5

Sign In or Register to comment.