Forum Visual Studio

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

VS2019 16.4 Debugger closes as soon as app launches?

I just recently (yesterday) updated to VS2019 16.4. Once i got everything building again (yay updates) I've found that when I launch my forms app over on the iOS Simulator, the debugger disconnects immediately. The app is still running and appears to be fine, but as soon as it deploys on the simulator and the splash screen comes up, VS just stops debugging.

I'm pretty sure it's something to do with my project, as a file > new doesn't have this problem, but I am lost on how to figure out what the issue is; there are no error logs, I've tried putting breakpoints at the entry point to the application and nothing ever trips, the debugger just closes.

Anyone seen something similar or have any recommendations on what could be causing the issue? I know it's not a lot to go on.

Answers

  • BPelottoBPelotto USMember

    I should mention that it works just fine if I roll back to VS2019 16.3.10 (with the exception of HotReload no longer working)

  • marc_rojasmarc_rojas Member ✭✭

    I'm in the same boat. I upgraded to VS 2019 16.4.1 and the debugger is not connecting to the simulator or a physical device. Checked logs and everything else. Not a single clue on what it might be causing this behavior.

    Do you have any warnings on your project regarding conflicting versions of the same dependent assembly or anything like that?

  • JohnHJohnH GBMember ✭✭✭✭✭

    Have you tried the usual clean and rebuild? Also try deleting the app off the simulator.

  • marc_rojasmarc_rojas Member ✭✭

    @JohnH said:
    Have you tried the usual clean and rebuild? Also try deleting the app off the simulator.

    Yes. In my case, I've tried the following:

    • Removing the app from the simulator
    • Resetting the simulator
    • Cleaning and rebuilding the project
    • Deleting the content of the bin and obj folders
    • Rebooting the Mac machine

    Still no luck. As I mentioned in my previous post, my only suspect at the moment is the conflicting version of the dependent assembly. Which VS2019 doesn't say which is the assembly causing the conflict...

  • marc_rojasmarc_rojas Member ✭✭

    Just sharing in case somebody is stuck with this problem. I downgraded Visual Studio 2019 to version 16.3.1 and now I can launch and debug my app without any issues. No changes on the project.

  • rickfuzzyrickfuzzy Member

    Same issue still in preview 17.4

Sign In or Register to comment.