Mono version required on Mac...

I wrote a Xamarin Forms app in Nov 2017 using Visual Studio 2017 and compiled it for iOS using a MacInCloud.com managed server. In June 2019 I started making updates to the app and had to upgrade Mono on the Mac to 5.18.1.28 and was still using VS2017 (v15.9.6). I haven't connected to the Mac since then, but now I try to connect to the MacInCloud.com server, I get a message indicating that Mono 6.4 is required for compatibility. I'm not aware of any NuGet packages that were updated and specifically, the Xamarin Forms package appears to be the same as earlier in the year. The MacInCloud people say their managed server standard for Mono for that macOS (High Sierra) is 5.18.1.28 and won't install 6.4. VS2019 is not an option because of my customer, but the macOS version can be changed if needed...

So, my question is, how do I set the version of Mono for the iOS compiler to 5.18.1.28 so that I can continue to use VS2017?

Tagged:

Answers

  • JoeMankeJoeManke USMember ✭✭✭✭✭

    I believe the Mono version is tied to the Xamarin.iOS version which is tied to the Visual Studio version. So if you downgrade your VS2017 you may get it to work, but I would recommend going the route of updating to a newer MacOS.

Sign In or Register to comment.