[VS on Mac] Can't add Apple Developer Account "No such host is known"

Hello, I updated VS 2019 to 8.3.8 (build 8) version on Mac Catalina 10.15.1

After that update, I can't add Apple Developer Account, I get this error:

I can login in Apple portal and Apple Developer Portal with this account. Any idea?

Tagged:

Best Answer

Answers

  • FalkognacFalkognac Member

    I'm experiencing the same issue here.
    Running Visual Studio for Mac Version 8.3.9 (build 2) on Mac Mohave 10.14.6

    Curiously, when inputting incorrect credentials for the account I do receive a message saying as much, and I only receive the above error when valid credentials are input.

  • TehNoob2010TehNoob2010 Member
    edited November 19

    Still stuck with this error after updating my Visual Studio Mac.

    I'm on Visual Studio for Mac Version 8.3.9 (build 2) on macOS Mojave 10.14.6 also.

    Hopefully this is resolved quickly as I can't submit my app to the appstore for submission because of it!

    EDIT:

    Updated to Version 8.4 Preview (8.4 build 2535) and I still am facing the same issue.

  • lopezcjflopezcjf Member

    I have the same issue using Visual Studio on Windows. The login popup freezes and no error appears. But I can see the same message on the log file

  • NyO1NyO1 Member

    Same here using Visual Studio 2019 on Windows, no error message is displayed and can't add any Apple Account.

  • mattmortonmattmorton USMember

    I'm running Visual Studio on Mac for crying out loud and even my install throws out the same error "No such host is known"

    Visual Studio For Mac (Community) 19 (Version 8.3.9)

    And this all started happening right after updating my Mac to Catalina and subsequently having to update Visual Studio.

  • davjvodavjvo Member
    edited November 19

    Had the same problem on vs for mac 8.3.9 and xcode 11.2.1, my work around was to add the signing certificate directly from xcode by creating a dummy application and assigning the app bundle, after xcode downloaded the certificate I could run my app on VS with no problem.

    Cheers

    Edit:

    Forgot to add that you have to manually sign it in VS with the corresponding provisioning profile

  • JosecanallaJosecanalla ARMember ✭✭
    edited November 19

    Updated VS to 8.3.9.2 and re-installed fastlane: https://docs.microsoft.com/en-us/xamarin/ios/deploy-test/provisioning/fastlane/

    But still the same issue.

    But now if I put incorrect credentials the error is "Invalid credentials"...

  • JosecanallaJosecanalla ARMember ✭✭
    Accepted Answer

    Solved installing VS version 8.3.10.2

  • Hey guys thanks for the help. i'm facing this issue as well/ I have been looking for the solution of this issue from the last 2 months.

  • TroyDawsonTroyDawson USMember ✭✭

    same issue here running the preview channel. downgrading to stable (8.3.10.2) and I could add my ADC account

Sign In or Register to comment.