Forum Xamarin.Forms
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

xamarin forms ios release build hangs

I'm running VS 2019 from my windows machine and connecting to my Mac through VS. I can successfully connect to the Mac without issue. The problem arises when I perform a release build, the build hangs on "compiling to native". When I cancel the build the following output is displayed on the output console:

5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : The client build16408Alpha has been disconnected while waiting a post response to topic xvs/Build/16.3.0.278/execute-task/UI.iOS/1951504002fMTouch 5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : An error occurred on the underlying client while executing an operation. Details: The client has been disconnected while trying to perform the unsubscribe to topics: xma/last-will 5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : The client build16408Alpha has been disconnected while waiting a post response to topic xvs/Build/16.3.0.278/execute-task/UI.iOS/1951504002fMTouch 5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : at Xamarin.Messaging.Client.MessagingClient.d__232.MoveNext() in E:\A_work\445\s\External\messaging\src\Xamarin.Messaging.Client\MessagingClient.cs:line 175
5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : System.Net.Mqtt.MqttClientException: The client has been disconnected while trying to perform the unsubscribe to topics: xma/last-will
5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : at System.Net.Mqtt.Sdk.MqttClientImpl.d__33.MoveNext() in E:\A_work\2653\s\src\Client\Sdk\MqttClientImpl.cs:line 302
5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : --- End of stack trace from previous location where exception was thrown ---
5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): warning : at Xamarin.Messaging.Client.TopicObservable1.d.MoveNext() in E:\A_work\445\s\External\messaging\src\Xamarin.Messaging.Client\TopicObservable.cs:line 32 5>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(842,3): error : The client build16408Alpha has been disconnected while waiting a post response to topic xvs/Build/16.3.0.278/execute-task/UI.iOS/1951504002fMTouch

It seems like the connection to the Mac drops off midway when performing a release build. All my software is up to date. I can also run the iOS simulators on the Mac in debug mode. Any help would be much appreciated.. Thanks in advance !

Best Answer

  • sachinkanadiasachinkanadia GBMember ✭✭
    Accepted Answer

    I managed to resolve this issue. Thanks @ColeX

    The problem was the iOS build config, once I configured it correctly I just had to wait (quite a while) to let the build complete.

Answers

  • ColeXColeX Member, Xamarin Team Xamurai

    It seems like the connection to the Mac drops off midway when performing a release build.

    Could you try to build in release mode on mac to see if problem persists ?

  • sachinkanadiasachinkanadia GBMember ✭✭
    Accepted Answer

    I managed to resolve this issue. Thanks @ColeX

    The problem was the iOS build config, once I configured it correctly I just had to wait (quite a while) to let the build complete.

  • InghamIngham FRMember ✭✭

    @sachinkanadia Could you please explain what was exactly the problem with your iOS build config ? I'm facing a similar problem and I'm trying a lot of things...

  • alizobializobi TRMember

    I'm facing a similar problem and I'm trying a lot of things too.
    Could You explain your settings

Sign In or Register to comment.