Cannot Run App on iOS After Update Visual Studio 2019, Please Help :)

Hi, i'm facing a strange situation,

After Updating Visual Studio 2019, i'm not able to run the application in iOS, this happen when i try to run from a Windows Computer Linked to a Mac.
But when i run the app using Visual Studio for Mac instead of windows, the app run without issues.

I looked into VS configurations and paths for Xcode and are correct (/Applications/Xcode.app).The path on the Mac exists and are reachables.

I tried the following solution, but it doesn't work:
Open simulator -- > click on the top menu Simulator --> click on **Reset Content and Settings.... **
Also in both Windows and Mac the Architectures are x86_64.

The ouput for VS on Windows:
Output Console:

The app has been terminated.
Launch failed. The app 'AppName' could not be launched on 'iPhone 11 iOS 13.2'. Error: error HE0042: Could not launch the app 'PackageName' on the device 'iOS 13.2 (17B84) - iPhone 11': The request to open "PackageName" failed.. Please check the logs for more details.
The app has been terminated.

**Build Output: **
Using Xcode 11.2 found in /Applications/Xcode.app/Contents/Developer
Xamarin.Hosting: Xamarin.Hosting
Xamarin.Hosting: Version: 3064e2c463 (d16-3)
Xamarin.Hosting: Xcode: /Applications/Xcode.app
Xamarin.Hosting: Xcode Version: 11.2
Xamarin.Hosting: Verbosity: 1
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTFoundation.framework/Versions/A/DVTFoundation
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTiPhoneSimulatorRemoteClient.framework/DVTiPhoneSimulatorRemoteClient
Xamarin.Hosting: Loaded /Library/Developer/PrivateFrameworks/CoreSimulator.framework/CoreSimulator
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DTDeviceKitBase.framework/DTDeviceKitBase
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTKit.framework/DVTKit
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DTDeviceKit.framework/DTDeviceKit
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DTXConnectionServices.framework/DTXConnectionServices
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTSourceControl.framework/DVTSourceControl
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTServices.framework/DVTServices
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTPortal.framework/DVTPortal
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTDocumentation.framework/DVTDocumentation
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTAnalyticsClient.framework/DVTAnalyticsClient
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTAnalytics.framework/DVTAnalytics
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/SourceKit.framework/SourceKit
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/Frameworks/IDEFoundation.framework/IDEFoundation
Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/IDEProducts.framework/IDEProducts
Xamarin.Hosting: Simulator watchdogs are not disabled for 'iOS 13.2 (17B84) - iPhone 11'.
Xamarin.Hosting: Shutting down simulator...
Xamarin.Hosting: Successfully disabled simulator watchdogs for 'iOS 13.2 (17B84) - iPhone 11'.
Xamarin.Hosting: Launching simulator application 'com.apple.iphonesimulator'
Xamarin.Hosting: Booting iPhone 11...
Xamarin.Hosting: Booted iPhone 11 successfully.
Xamarin.Hosting: No need to boot (already booted): iPhone 11
Xamarin.Hosting: Installing /Users/angyay0/Library/Caches/Xamarin/mtbs/builds/App.iOS/fb8bb79d47458ad099aab10c40ce7836/bin/iPhoneSimulator/Debug/App.iOS.app with Bundle Identifier PackageName on 'iOS 13.2 (17B84) - iPhone 11'...
Xamarin.Hosting: Installed 'PackageName' from /Users/angyay0/Library/Caches/Xamarin/mtbs/builds/App.iOS/fb8bb79d47458ad099aab10c40ce7836/bin/iPhoneSimulator/Debug/App.iOS.app
Xamarin.Hosting: Could not find any potentially troublesome weak load commands.
Xamarin.Hosting: The bundle id PackageName was successfully installed.
Xamarin.Hosting: Creating shared memory for:
__XAMARIN_DEBUG_PORT__=59082
Xamarin.Hosting: Created shared memory id: 65536
Xamarin.Hosting: Mapped shared memory: 0x1091ff000 for key 301399 and id 65536
Xamarin.Hosting: Launching com.hebmex.sg on 'iOS 13.2 (17B84) - iPhone 11'
Xamarin.Hosting: Could not launch the app 'PackageName' on the device 'iOS 13.2 (17B84) - iPhone 11': The request to open "PackageName" failed., will try to reinstall the app
Xamarin.Hosting: Created shared memory token: 301399
Xamarin.Hosting: Installing /Users/angyay0/Library/Caches/Xamarin/mtbs/builds/App.iOS/fb8bb79d47458ad099aab10c40ce7836/bin/iPhoneSimulator/Debug/App.iOS.app with Bundle Identifier PackageName on 'iOS 13.2 (17B84) - iPhone 11'...
Xamarin.Hosting: Installed 'PackageName' from /Users/angyay0/Library/Caches/Xamarin/mtbs/buildsApp.iOS/fb8bb79d47458ad099aab10c40ce7836/bin/iPhoneSimulator/Debug/App.iOS.app
Xamarin.Hosting: Could not find any potentially troublesome weak load commands.

I attached the Output from Console for iOS Log.

Windows Computer:
Visual Studio 2019 Professional Version 16.3.7
Xamarin.iOS and Xamarin.Mac SDK - 13.4.0.2 (e37549b)

Mac:
Visual Studio 2019 Enterprise for Mac Version 8.3.5 (build 13)
Xcode 11.2 (11B52)
Xamarin.iOS and Xamarin.Mac SDK - 13.4.0.2 (e37549bc)

Thanks.

Sign In or Register to comment.