Xamarin Studio Crashes at Startup

I am trying to run Xamarin Studio 5.0 build 878 on a Windows 8.1 machine. When attempting to launch the IDE, it looks like it is almost finished loading and then crashes. I have completely uninstalled and reinstalled all aspects of Xamarin, but that didn't seem to help. The IDE log is attached. Thoughts on what may be wrong?

Posts

  • mhutchmhutch USXamarin Team Xamurai

    The error causing the crash is:

    ERROR [2014-05-29 22:31:08Z]: 
    System.TypeInitializationException: The type initializer for 'MonoDevelop.Ide.TypeSystem.TypeSystemService' threw an exception. ---> System.MissingMethodException: Method not found: 'System.String ICSharpCode.NRefactory.TypeSystem.IUnresolvedAssembly.get_FullAssemblyName()'.
    

    It looks like one of your assemblies is from an older version. Try uninstalling and reinstalling Xamarin Studio.
    at MonoDevelop.Ide.TypeSystem.TypeSystemService..cctor()

  • JeffreyYoungJeffreyYoung USMember

    If you see in my first comment, I clearly state that I uninstalled and reinstalled everything as a first step. I even tried a second time deleting all files from program files folders, etc. Is there anywhere else any Xamarin components are stored? Maybe in the GAC or somewhere else?

  • mhutchmhutch USXamarin Team Xamurai
    edited May 2014

    XS doesn't install anything in the GAC. It's strange that particular method is missing since it was added to NRefactory well over 18 month ago, which implies you have a very old version of NRefactory coming from somewhere. Could you check the GAC for ICSharpCode.NRefactory.dll, and maybe run a file search for ICSharpCode.NRefactory.dll in case something else on your machine is somehow overriding this dll?

  • JeffreyYoungJeffreyYoung USMember

    I found that a version of this DLL was being installed by a third party app. I removed the faulting app and now Xamarin Studio works just fine. Thanks for the help!

  • mhutchmhutch USXamarin Team Xamurai

    Glad that fixed it! Not sure how a GAC assembly could override a local copy, but ICSharpCode.NRefactory should never be in the GAC so I'm pretty sure that app is at fault.

Sign In or Register to comment.