Android Bindings Library - Unsupported Java Version error

I am trying to use a .jar file in my Xamarin Android Project. I created a Bindings Library Project, added the .jar file as an embeddedJar, and built the project. When trying to build the Android project which references the bindings project I receive the following error:

Can't process class [META-INF/versions/9/module-info.class] (Unsupported class version number [53.0] (maximum 52.0, Java 1.8

I found similar issues online with a mismatch between versions 52 and 51 where the solution was to install the latest version of Proguard. I have tried using version 6.2 but I then receive the following error:

java.exe" exited with code 1

How can I resolve this? I am using Visual Studio 2019 and Android API 28. Thank you

Answers

Sign In or Register to comment.