Xamarin iOS : Build apps with error - One or more errors occurred

WeiLoonWongWeiLoonWong USMember ✭✭
edited October 11 in Xamarin.iOS

I'm using Visual Studio 2017 version 15.9.15 on Windows10. Today I try build and deploy my iOS project, with no reason I get error message - One or more errors occurred . When I click on the error message, it brings me to this line of code
<CopyFilesToBuildServer SessionId="$(BuildSessionId)" Files="@(_CopyFilesToMacOutput);@(_NoneWithCopyToOutputDirectory)" />.
This error only happened when I select Debug mode, Release mode worked good.
I really lack of ideas what had happened, can anyone give me some advice?

Tagged:

Best Answer

  • WeiLoonWongWeiLoonWong US ✭✭
    edited October 17 Accepted Answer

    End up I resolve the issues by :
    (1) updates Visual Studio 2017 to version 15.9.17
    (2) repair Visual Studio 2017
    (3) clone again my project into different folder
    (4) Build and run the project

Answers

  • PareshSukhiyaPareshSukhiya USMember ✭✭

    Is it happening over device and simulators or only on either one of those?

  • WeiLoonWongWeiLoonWong USMember ✭✭

    It's happened on devices. I'm using iPhoneX (iOS 13.1.1)

  • ColeXColeX Member, Xamarin Team Xamurai
    1. Try to update visual studio to 2019 .

    2. Ensure you've selected Don't Link on Linker Behavior in project configuration.

  • WeiLoonWongWeiLoonWong USMember ✭✭

    @ColeX I changed link behavior to Don't Link but no luck.
    And so far we have no plan to migrate to Visual Studio 2019 yet. Fyi, my colleague with same version of Visual Studio 2017 able to build and deploy iOS project. Do you have any ideas?

  • ColeXColeX Member, Xamarin Team Xamurai

    Try to reinstall vs or create a blank project and move you file into it one by one to figure out the cause .

  • WeiLoonWongWeiLoonWong USMember ✭✭
    edited October 17 Accepted Answer

    End up I resolve the issues by :
    (1) updates Visual Studio 2017 to version 15.9.17
    (2) repair Visual Studio 2017
    (3) clone again my project into different folder
    (4) Build and run the project

  • ColeXColeX Member, Xamarin Team Xamurai

    @WeiLoonWong said:
    End up I resolve the issues by :
    (1) updates Visual Studio 2017 to version 15.9.17
    (2) repair Visual Studio 2017
    (3) clone again my project into different folder
    (4) Build and run the project

    Please accept your solution as answer .

Sign In or Register to comment.