Trouble with mono dependancy

Hello Xamarin Forum,

we recently converted our xamarin.mac classic api app (retail version, NOT for appstore) into a unified app. Now when the app is started on a machine where mono framework is not installed it crashes instantly. Before the conversion we used an old mono library (which uses Classic API) to test whether mono is installed or not and then give the user a dialog with the option to download mono.
Now we need a new implementation to check if mono framework is installed and at least show an information dialog for the user so they know they have to install mono first.

Tagged:

Best Answer

  • ChrisHamonsChrisHamons US Xamurai
    Accepted Answer

    What target framework are you using?

    In theory, Modern or Full should not require mono installed. If you are using System, consider moving to one of the supported options (and side stepping this issue completely).

Answers

  • ChrisHamonsChrisHamons USForum Administrator, Xamarin Team Xamurai
    Accepted Answer

    What target framework are you using?

    In theory, Modern or Full should not require mono installed. If you are using System, consider moving to one of the supported options (and side stepping this issue completely).

Sign In or Register to comment.