Inspector not working VS 2019 Mac

mstoneraptosmstoneraptos ✭✭Member ✭✭

Using a new project with the default android app template causes the Inspector button to not be available. Log shows this error when starting app in android 8 or 9 emulators:

ERROR [2019-09-20 11:32:12Z]: InspectorDebugSession(2): AgentBridge.InjectAssembly
System.NullReferenceException: Object reference not set to an instance of an object
  at Xamarin.Interactive.IdeSupport.AgentBridge.StartBreakdance () [0x0006c] in <89de59b91d354b66959baa2a2d4979fd>:0 
  at Xamarin.Interactive.IdeSupport.InspectorDebuggerSession+<>c__DisplayClass25_0.<HandleTargetEvent>b__0 (System.Object <p0>) [0x0008d] in <89de59b91d354b66959baa2a2d4979fd>:0``

Is this simply broken in latest VS Mac 2019? Using:
VS Mac - Enterprise 8.2.6 build 26
All latest Xamarin updates applied from stable channel

Have folllowed all instructions from MS Doc about Inspector. New app template already had the proper build options selected anyway

Answers

  • LeonLuLeonLu Xamurai Member, Xamarin Team Xamurai

    First of all, please check the Requirements for your environment,

    Must target Android >= 4.0.3, with fastdev enabled.
    Must use Google, Visual Studio, or Xamarin Android emulators. Android 7 emulators may not allow inspection at this time.

    If your issue is related to the inspector, Here is Designated forum, you can ask on it.
    https://forums.xamarin.com/categories/inspector

  • mstoneraptosmstoneraptos ✭✭ Member ✭✭

    As I said in my post, already followed those instructions. Plus this is using the app template from VS itself, not a custom project. Will move post to other forum thanks

  • mstoneraptosmstoneraptos ✭✭ Member ✭✭

    Also, that forum you linked is old and asking a new question via this UI does not allow that forum as a choice - appears to be a dead forum

Sign In or Register to comment.