App ad-hoc installs OK on ARMv7 (ios9) iPads but not on ARM64 (ios12) iPads

Hi,

I have a Xamarin.IOS app, developed in Windows Visual Studio connected to a MacInCloud session (noted as I am unable to connect devices directly).

I have followed the Ad Hoc and IPA processes in the Xamarin doco, and publish by dragging the IPA file on to the device in iTunes.

The app installs and operates correctly on an older (ios9) iPad, however on an ios12 iPad it "appears" to install - no objection or error in iTunes and an icon appears on the iPad - however this icon appears darkened, does not contain the application image, and the app does not start.

The app targets ARMv7 + ARM64 (I can target either one individually and observe iTunes refusing to install on the other iPad), linking framework SDKs only, and I am reasonably confident the bundle signing (certificates, identifiers, devices, profiles) are all OK (given the ios9 iPad success). Both iPads are registered devices and included in the profile.

I have tried tweaking the IOS Build, Info.plist and Entitlements.plist per any and all related posts with similar issues, all to no avail.

I have attached a logfile captured during installation on the ios12 iPad of (renamed) "com.xamarin.MyBundleId"

Thanks in advance for your assistance.

Neil.

Posts

  • Some further investigation may clarify your assistance.

    I downloaded docs.microsoft.com/en-us/samples/xamarin/ios-samples/ios11-draganddroptableview/, left this completely "as is" other than renaming to "com.xamarin.MyBundleId" (to utilize my existing certificates, identifiers, devices, profiles) and turning on IPA creation, then published as above ... and observed identical behavior (worked on ios9 iPad but not on ios12 iPad).

    I am completely stumped as to the reason why.

    Any assistance would be greatly appreciated.

    Neil.

Sign In or Register to comment.