Cannot start emulator

Could not start emulator.
To report a problem, choose "Report a problem" from the Help menu and attach the records.
Error message: "An attempt was made to load a program with an incorrect format."

I'm using VS in Windows Server 2016 Intel Xeon 24Gb RAM and Hyper-V.
I understand that I can use Hyper-V and it is not necessary to disable it.
Can I use Hyper-V instead of intel HAXM?

Regards

Answers

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    Of Course, Yes Microsoft's Hyper-V and the Hypervisor Platform and Intel's Hardware Accelerated Execution Manager (HAXM) are available for accelerating the Android emulator.

    For optimum performance, it is recommended that you use Hyper-V to accelerate the Android emulator. If Hyper-V is not available on your computer, then HAXM can be used.

    You can see this link.
    https://docs.microsoft.com/en-us/xamarin/android/get-started/installation/android-emulator/hardware-acceleration?pivots=windows

  • The hyper-v is running but the Android Emulator only run if, in the android device manager, the device uncheck x86 and check "arm64" or "armeabi processor

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    You cannot run the emulator of the x86, but the "arm64" or "armeabi processor of emulator could running normally, am I right? If so, you have enabled the hyper-v , you should check the Windows Hypervisor Platform as well, If this function is enabled like following screenshot.

    If not, please enable it, then restart your comptuer.

    Then, we should Update to Android Emulator 27.2.7 or above
    In Visual Studio, select Tools > Options > Android > Android SDK Manager. Click the Tools tab, select the Android Emulator component, and select Apply Changes.

Sign In or Register to comment.