Xamarin SVN Checkout

JamesGreen.8031JamesGreen.8031 GBMember ✭✭
edited May 2014 in General

Hi,

I have an SVN repository on my main Windows 7 development box that I can access from my Windows 8 VM running on my mac using the https:// protocol. I'm now trying to perform a checkout of this onto my OSX machine using Xamarin Studio but it simply cannot connect to the server.

MonoDevelop.VersionControl.Subversion.SubversionException: Unable to connect to a repository at URL 'https://jamhq/svn/MyRepoSvn'
OPTIONS of 'https://jamhq/svn/MyRepoSvn': could not connect to server (https://jamhq)
  at MonoDevelop.VersionControl.Subversion.Unix.SvnClient.CheckError (IntPtr error, Nullable`1 allowedError) [0x000aa] in /Users/builder/data/lanes/845/95ac543f/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:68 
  at MonoDevelop.VersionControl.Subversion.Unix.SvnClient.CheckError (IntPtr error) [0x0000b] in /Users/builder/data/lanes/845/95ac543f/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:44 
  at MonoDevelop.VersionControl.Subversion.Unix.UnixSvnBackend.CheckError (IntPtr error) [0x00001] in /Users/builder/data/lanes/845/95ac543f/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:221 
  at MonoDevelop.VersionControl.Subversion.Unix.UnixSvnBackend.Checkout (System.String url, FilePath path, MonoDevelop.VersionControl.Revision revision, Boolean recurse, IProgressMonitor monitor) [0x00078] in /Users/builder/data/lanes/845/95ac543f/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:786 

I always get the same could not connect to server error. I have a number of shared drives on the Windows 7 box that I can connect to no problems using Finder so my mac can definitely "see" the Windows 7 box.

Also when selecting the https protocol Xamarin Studio seems to want to start the URL with https:///.

Has anyone managed to get this setup working?

Thanks,

James.

Sign In or Register to comment.