Forum Xamarin.Android

The specified executable is not a valid application for this OS platform

CheegerCheeger RUMember ✭✭

The problem in VS2019 appears when deploying to a real device. On another machine with the same VS configuration and the same Android device, there are no problems. Someone faced?

Answers

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    What error did you get when deploying to a real device?

    Here are two tips when you handle this issue.

    1.Firstly, please update your VS and nuget packages to the latest version.

    2.If you can not deploy it, you can close the VS,then open your project, delete all of bin and obj folders, then rebuild it.

  • CheegerCheeger RUMember ✭✭
    edited August 2019

    @LeonLu said:
    What error did you get when deploying to a real device?

    Here are two tips when you handle this issue.

    1.Firstly, please update your VS and nuget packages to the latest version.

    2.If you can not deploy it, you can close the VS,then open your project, delete all of bin and obj folders, then rebuild it.

    Not work, as before:
    xa0000: unhandled exception: system.componentmodel.win32exception(0x80004005):The specified executable is not a valid application for this OS platform. In system.diagnostics.process.startwithcreateprocess(processstartinfo startinfo) in system.diagnostics.process.start() in xamarin.android.tasks.compilenativ

  • CheegerCheeger RUMember ✭✭
    I tried to copy the solution from another machine, tried to connect devices with different versions of android, the result does not change, what could be the problem?
  • CheegerCheeger RUMember ✭✭

    I tried to connect devices via Wi-Fi, have I tried everything I could, any ideas?
    XA0000: Unhandled exception: System.ComponentModel.Win32Exception (0x80004005): The specified executable is not a valid application for this OS platform. In System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo) in System.Diagnostics.Process.Start() in Xamarin.Android.Tasks.CompileNativeAssembly.RunAssembler(Config config) in Xamarin.Android.Tasks.CompileNativeAssembly.<RunParallelAssembler>b__15_0(Config config) in Xamarin.Android.Tasks.AsyncTaskExtensions.<>c__DisplayClass0_01.b__0(TSource s)`

  • LeonLuLeonLu Member, Xamarin Team Xamurai
  • CheegerCheeger RUMember ✭✭

    I already tried it

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    Did you test it in Visual studio 2017? Due to the policy, I cannot ask you for the whole project, I cannot test it for you. You can create free support by this link.
    https://support.microsoft.com/en-us/supportforbusiness/productselection?sapId=211dd84f-3474-c3c5-79bf-66db630c92a6

  • yacinekadda8yacinekadda8 Member

    Hey do you find a solution ?

  • KarluzKarluz Member ✭✭

    Any solution?

  • CheegerCheeger RUMember ✭✭

    Only use VS2017 or reinstall Windows

  • KarluzKarluz Member ✭✭

    Already done the second one. Didn't resolve. :tired_face:

Sign In or Register to comment.