Cannot run iOS tests with Xcode 11 beta

Hi all,

I am getting an error when trying to run a Xamarin UI Test on an iOS simulator. The error was caused by installing the Xcode 11 beta and I can't find any documentation on this specific error:

System.IO.FileNotFoundException : Could not find file '/var/folders/0v/gljl5qsd1gq92c7wrbm8h7100000gn/T/uitest/a-E94E754E7485E6283B3D522AFEFBDAEC4D8DE1C7/1538/defaultSimDeviceIdentierForInstumentsBuild-Xcode11'.

When on the stable channel, I get the same error but with file /defaultSimDeviceIdentierForInstumentsBuild-Xcode10.

Stack Trace:
at System.IO.File.Move (System.String sourceFileName, System.String destFileName) [0x0008a] in /Users/builder/jenkins/workspace/build-package-osx-mono/2019-02/external/bockbuild/builds/mono-x64/external/corefx/src/System.IO.FileSystem/src/System/IO/File.cs:645
at Xamarin.UITest.Shared.Artifacts.ArtifactFolder.CreateArtifact (System.String artifactName, System.Action`1[T] createAction) [0x00093] in <18ae7883e2424c558186d1d9edf9f14b>:0
at Xamarin.UITest.iOS.Instruments.GetDefaultSimDeviceIdentifier (System.Int32 xcodeVersion) [0x00016] in <18ae7883e2424c558186d1d9edf9f14b>:0
at Xamarin.UITest.iOS.iOSAppLauncher.GetOrValidateSimId (Xamarin.UITest.iOS.Instruments instruments, System.String deviceIdentifier) [0x0002b] in <18ae7883e2424c558186d1d9edf9f14b>:0
at Xamarin.UITest.iOS.iOSAppLauncher.LaunchAppLocal (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration, Xamarin.UITest.Shared.Http.HttpClient httpClient, System.Boolean clearAppData) [0x00113] in <18ae7883e2424c558186d1d9edf9f14b>:0
at Xamarin.UITest.iOS.iOSAppLauncher.LaunchApp (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration, Xamarin.UITest.Shared.Http.HttpClient httpClient, Xamarin.UITest.TestCloud.TestCloudiOSAppConfiguration testCloudAppConfiguration, Xamarin.UITest.Shared.Http.HttpClient testCloudWsClient, Xamarin.UITest.Shared.Http.HttpClient xtcServicesClient, System.Boolean testCloudUseDeviceAgent) [0x00068] in <18ae7883e2424c558186d1d9edf9f14b>:0
at Xamarin.UITest.iOS.iOSApp..ctor (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration, Xamarin.UITest.Shared.Execution.IExecutor executor) [0x0028d] in <18ae7883e2424c558186d1d9edf9f14b>:0
at Xamarin.UITest.iOS.iOSApp..ctor (Xamarin.UITest.Configuration.IiOSAppConfiguration appConfiguration) [0x00000] in <18ae7883e2424c558186d1d9edf9f14b>:0
at Xamarin.UITest.Configuration.iOSAppConfigurator.StartApp (Xamarin.UITest.Configuration.AppDataMode appDataMode) [0x00017] in <18ae7883e2424c558186d1d9edf9f14b>:0

I am able to build the project to a simulator, I only get this error when trying to launch the simulator via a test run. The app launch is pretty straightforward:

ConfigureApp
.iOS
.AppBundle(AppPath)
.StartApp();

I've tried uninstalling and reinstalling Xcode 10.3 and the beta (and command line tools), and am up to date on the Xcode 11 Previews channel. The only thing I can think of is that I'm using Xcode 11 beta 6 and maybe something changed that the Previews channel updates don't cover in the most recent versions?

Any ideas are appreciated!

Posts

  • enroubenroub USMember ✭✭

    Hi @cjwilson . Did you find any solution to this one? I am also facing the same problem though my XCode is 10.3. If ever you found out a solution can you post it also here. Thanks.

Sign In or Register to comment.