why is skiasharp.views.forms not found in skiasharp.views

AustyAusty Member ✭✭✭

l installed skiasharp.views nuget package in my project and l am trying to add the using directive skiasharp.views.forms and l get the error type or namespace not found. if l then decide to use just "using skiasharp" l get the same error when trying to instantiate a skcanvasview object. kindly help.

Answers

  • DirkWilhelmDirkWilhelm USMember ✭✭✭✭

    Install the Skiasharp.Views.Forms nuget package: https://www.nuget.org/packages/SkiaSharp.Views.Forms

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    If you have installed the SkiaSharp.Views.Forms nuget package and using SkiaSharp.Views.Forms;, but you still get the Skiasharp.views.forms not found, you can delete all of the bin and obj folders in your project, rebuild your project,

  • AustyAusty Member ✭✭✭

    @LeonLu when l install skiasharp.views.forms l get the notification that skiasharp.views added with warnings. and when l try to add the using directive "using skiasharp.views.forms" intelisense only provide the following options

    Desktop
    GTK
    wfp..

    Is this ok and which should l choose if its ok

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    If you want to use it in xamarin forms, we add following two nuget packages

    https://www.nuget.org/packages/SkiaSharp

    https://www.nuget.org/packages/SkiaSharp.Views.Forms

  • AustyAusty Member ✭✭✭

    @LeonLu l have installed both but l am getting the same error as before

  • AustyAusty Member ✭✭✭

    @LeonLu any ideas on how to solve my issue.Below is the exact warning l have on skiasharp.views.forms nuget package after installation

    Package 'Skiasharp.Views. 16.8.0' was restored using '.NetFramework,Version=v4.6.1' instead of the project target framework '.NetStandard,Version=v2.0'. This package may not be fully compatible with your project.

  • LeonLuLeonLu Member, Xamarin Team Xamurai
    edited August 20

    Please open the Manage Nuget packages, update other nuget packckages to the latest, please do the same work in .android and .IOS project.

Sign In or Register to comment.