AppHance Bindings for iOS working in Simulator not on device

JonCarlosJonCarlos GBUniversity ✭✭

Hi

I wondered if there was anything obvious I should look for if I have a binding that works perfectly in the simulator but not when installed on the device.

What I've done so far is pretty simple, run Objective Sharpie on the header file for the API, Copy the lib file with the a extension to the binding project folder, strip off all the binding checks in the class output by Objective Sharpie. I've also added --gcc_flags -ObjC to the iOS Build mtouch arguments.

I've followed the guide on the AppHance site for starting a new session which basically is APHLogger.StartNewSessionWithApplicationKey ("App Key Here");

When I run this in the simulator is works perfectly, I can even configure the thing by modifying the default settings. However when I run it on the device I get Null Refs.

Is there something obvious I've missed when getting the lib on to the device that would cause this kind of issue?

You can find the lib at https://help.apphance.com/library-installation/ios I'm using the Pre-Production version for testing the app before release.

Thanks

Posts

Sign In or Register to comment.