WCF client and system web proxy

I can connect a xamarin android WCfclient to a WCF server hosted in a windows service, that works, but it always use the http proxy define en the APN settings. I set there properties(in the basichttpbinding****) as follow :
bypassProxyOnLocal = true
proxyAddress = null
useDefaultWebProxy = false
And it still use the http proxy.
How can I make my xamarin android app to completly ignore any proxy settings, APN or Wifi, I just want to connecto directly to the WCF service server.
Please help

Answers

  • jezhjezh Member, Xamarin Team Xamurai
    edited July 12

    You can try to check the server enviroment in computer:

    echo $http_proxy
    echo $https_proxy
    echo $HTTPS_PROXY
    echo $HTTP_PROXY
    

    and delete with export http_proxy=

    Or check https proxy

     git config --global --unset https.proxy
    

    Or do you have the proxy in the local config?

    git config --unset http.proxy
    git config --unset https.proxy
    
  • SkullwarriorSkullwarrior Member ✭✭

    Has I said before, this happen with xamarin android apk, I'm making an Android app with xamarin + VS2017, and using WCF to connect to a WCF service using basichttpbinding, and no matter the settings to avoid system proxy, it always use it, I repeat the settings:
    bypassProxyOnLocal = true
    proxyAddress = null
    useDefaultWebProxy = false

Sign In or Register to comment.