Forum General

Xamarin Installation Not Working



  • I successfully installed the xamrin on my machine ...

  • JonLippertJonLippert USMember
    edited September 2014

    So, I'm having the same issue as above: xamarininstaller.exe does nothing. I tried to use the manual instructions here: Unfortunately, when I get to step #5 to install and xamarin.ios, the only option that I have to download is the installer itself again. Any help?

    Disregard. I found them. Thanks.

  • Hai,

    i have the same problem. i have downloaded xamarininstaller.exe but it disappears. i have the error log. please someone help.

  • I'm facing the same issue ! any updates about it

  • I'm having installation problems. I tried installing Xamarin several months ago and I had problems with the required Visual Studio upgrade. So I left it and decided to try again now.
    When I first ran the installer, it produced an error log. I tried again and got the "install individual" and got a second error log. Both are in the attached file error log

    There was no xamarin even after restarting, so reading this, I uninstalled all the xamarin, checked that I had .net 4.5 and tried again. Bizarrely I had to install two copies of Xamarin installer.

    Now when I run the download it opens, asks for logging and disappears. The error log shows an error installing mono but then indicates success but no xamarin is installed, just the platform tools android sdk and "open java window' I'm enclosing the second error log.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @AlaaQaddoumi‌, thanks for the report! There was a mistake where the latest installers were signed with certificates that have just expired today (November 21).

    If needed, you can work around the problem temporarily by setting back your computer clock by 1 day. See this new thread for more details:

  • RaymondBradyRaymondBrady USMember

    Same problem here on Win7. No Visual Studio.

    Chocolatey to the rescue:
    choco install xamarin-visualstudio

    Now I can build and run TaskyAndroid
    (I ran choco from administrator prompt)

  • addseo1118addseo1118 THMember

    hoooo thank for trick. goodjob

  • addseo1118addseo1118 THMember

    Thanks for new learning. Your posts are so useful for me. Nice thread.

  • Abigail1509Abigail1509 UAMember

    I'm having the exact same problem as ChrisGW!

  • JosMendozaJosMendoza USMember
    edited June 2015

    I have read the entire 3 pages of this thread.
    I browsed on internet about other possible solutions to try solve my problems on Xamarin installation like this page, and other many pages.

    So far so good, the conclusion I learned is this (after 4 installations on 3 different computers):
    If Xamarin installer would have the 0.001 of reliability of (for example) Microsoft Visual Studio Installer, that will be great.

    I think than in the future the perfect solution will be to pack Xamarin on a bundle containing:
    A Windows 7 Virtual Machine containing Xamarin "pre-installed" and "fully" configured.
    But, the problem now will be the size of that mega-file.

    I must persevere on try to making-work Xamarin, or in the future I'll have to do native-coding (the goal is avoid that).

    That was my sad story with Xamarin.


  • AbuFakhirahAbuFakhirah USMember

    This is the solution i have :

    1. install dotnetframework 4.5, if you have problem while installing, follow this link to solve it

    2. install xamarin again

    I hope this work for you guys

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    I have wrote a starter-guide some time ago, that could be useful generally to start with Xamarin. You can find it here:

  • RameshAlpulaRameshAlpula INMember

    I am unable to use visual studio 2013 professional with the indie license but in vs2010 professional indie license is working fine.reply me

  • Xamarin-IanXamarin-Ian USMember, Xamarin Team Xamurai

    Visual Studio support is not available with an indie license with VS2010, VS2012, or VS2013. Please let me know if you have any other questions.

  • chhaylyyeangchhaylyyeang USMember

    I use xamarin 4.0.8(window), can not build app for android 5.0.2


    Hello,I had the same problem. That was caused by my antivirus programm. You can not just disable it, because many antivirus programs using "self-defence". So if you want to actually install Xamarin - delete your antivirus and try to install Xamarin again.

  • @ANDREW_S said:
    Hello,I had the same problem. That was caused by my antivirus programm. You can not just disable it, because many antivirus programs using "self-defence". So if you want to actually install Xamarin - delete your antivirus and try to install Xamarin again.

    That is a load of crap. Antivirus programs doesn't block installations without telling you. I cannot install xamarin studio now, and it's for sure not due to any antivirus programs not being uninstalled. I don't HAVE one. However, I have a working visual studio installation and now it keeps telling me - during install - that I need to install xamarin before xamarin studio. While I have it installed.

    Apparently the dual-faced installation of standalone or with visual studio was more than the programmers of xamarin could handle, and therefore - it fails. Every time. No particular reason either, but that's MS for you.

  • KyawNaingTunKyawNaingTun USMember

    I download the Xamarin.VisualStudio_4.1.0.530.msi
    while installing ahalf " The cabinet file '' required for this installation is corrupt and cannot be used . This could inidicate a network error , an error reading from the CD_ROM , or a problem with the package " that message appear and than stop the installation.
    How can i get the full version of xamarin for vs ?
    Please share me a direct link to download that package.
    Thanks .

  • @ANDREW_S said:
    Hello,I had the same problem. That was caused by my antivirus programm. You can not just disable it, because many antivirus programs using "self-defence". So if you want to actually install Xamarin - delete your antivirus and try to install Xamarin again.

    This worked for me. Installs ok after disable Microsoft Security Essentials.

  • ashkoretashkoret CHMember


    I cannot install Xamarin.VisualStudio_4.3.0.784.msi, I think the problem is the download, the progress bar says
    Current download: Xamarin.VisualStudio_4.3.0.784.msi (747MB)
    but then below "Completed: XXX MB out of 813MB at X MB/s",
    and the actual file I received is 746 Mb.

    So which size is it?

    Then installation fails, recommends to download the same installer. So I did that, ran it, it says it cannot open a DLL.
    So I tried to run it as administrator -> Error: Installation package could not be opened.
    I tried to open it with WinRAR - says archive is corrupt.
    Tried to download it several times - same result.

  • AshleyGazichAshleyGazich USMember, Xamarin Team Xamurai

    This thread is quite old and may not be relevant for the issue you are having. For troubleshooting a new scenario that is not resolved by the steps earlier in this thread, I would recommend creating a new forum discussion or question. Including installer logs and exact error messages in the new post would be much appreciated.

    Just in case you have not already seen them, here are the Windows manual installation guides for Xamarin.iOS and Xamarin.Android. Xamarin installers can be found via Xamarin account downloads section.

  • TomWessonTomWesson USMember

    3,000 years later it still doesn't work

  • AshleyGazichAshleyGazich USMember, Xamarin Team Xamurai


    Thanks for posting to the forums! This thread is fairly aged; I'd suggest creating a new question or discussion for assistance with the issue you are encountering. Including details such as whether Xamarin is being installed on Windows or Mac, full text of any errors encountered, and related logs would be a great start. Thanks!

Sign In or Register to comment.