Forum General

Can no longer debug in the Android emulator from Visual Studio

mgregory22mgregory22 Member ✭✭

I had this working but it quit working when I got the latest update for Visual Studio. I don't know what actually caused the problem.

The story is I created a Xamarin Forms project, hit debug, and it opened the Android Device Manager. I made a device, and the device was named in the debug menu thing. When I clicked that device, it would open in the emulated device.

Next, I got a USB cable for my new phone, hooked it up and I was able debug from either the emulator or the actual phone.

I upgraded Visual Studio and it just hasn't worked since. The debug just has two items that say "Android Emulator" and one the says "Create Android Emulator...". All they do is open up the Android Device Manager. I've tried deleting the device and recreating it, but no dice.

Oh, but now there's an error message that's popped up. It says:

Device Manager

Device error: error: device unauthorized.
This adb server's $ADB_VENDOR_KEYS is not set
Try 'adb kill-server' if that seems wrong.
Otherwise check for a confirmation dialog on your device.

I don't know why I need authorization. I just want to run my cheesy little app.


  • mgregory22mgregory22 Member ✭✭
    edited June 2019

    It says "The debug was canceled. Please create an android emulator to debug the application." in the Visual Studio output window. It just doesn't see the emulators that I make.

Sign In or Register to comment.