Forum Xamarin.Android

What libraries am I missing? How would I find this out?

RonNYCRonNYC Member ✭✭✭

ADB0010: Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries,

Severity Code Description Project File Line Suppression State
Error ADB0010: Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]
at Mono.AndroidTools.Internal.AdbOutputParsing.CheckInstallSuccess(String output, String packageName)
at Mono.AndroidTools.AndroidDevice.<>c__DisplayClass94_0.b__0(Task1 t) at System.Threading.Tasks.ContinuationTaskFromResultTask1.InnerInvoke()
at System.Threading.Tasks.Task.Execute()

Tagged:

Answers

  • RonNYCRonNYC Member ✭✭✭

    I think I'm using ADB version 1.0.32. But what version do I need? What libraries?

  • LeonLuLeonLu Member, Xamarin Team Xamurai

    The reason for this error is that your application uses native libraries (NDK, Native Lib). The compilation target of these libraries is usually the cpu of the arm architecture. This error is reported when running on x86. To fix out this issue, you just run your application on emulator of ARM.

  • RonNYCRonNYC Member ✭✭✭

    So I'm confused. I get that ADB error but I'm running the app on emulator_console_with_token(Anroid 8.1 - API27). The only choice I see is that or Android_Accelerated_X86_Oreo.

Sign In or Register to comment.