Xamarin Forms: Failed to launch the ios application on the device.

SreeeeSreeee INMember ✭✭✭✭✭
edited June 21 in Xamarin.Forms

Getting the following message when installing xamarin forms ios app in physical ios device.

NSLocalizedRecoverySuggestion=Please try rebooting and reconnecting the device. (0xE8000022)., NSLocalizedFailureReason=Please try rebooting and reconnecting the device. (0xE8000022).}
warning MT1043: Failed to launch the application using the instruments service. Will try launching the app using gdb service.
Launching 'appname' on the device 'iPhone'
warning HE0030: Could not mount developer tools on 'iPhone': Could not locate device support files.
warning HE0031: Failed to mount developer tools on 'iPhone'.
warning HE0030: Could not mount developer tools on 'iPhone': Could not locate device support files.
warning HE0031: Failed to mount developer tools on 'iPhone'.
error MT1007: Failed to launch the application 'appname' on the device 'My iPhone': Failed to launch the application 'apname 'My iPhone': Invalid Service >Error (error: 0xe8000022). You can still launch the application manually by tapping on it.

I am using visual studio for mac version 7.7.3(build 43), iPhone 7(12.3.1) and xcode(Version 10.1 (10B61))

I have installed Xcode on mac, not iPhone. Is Xcode need to install on the iPhone for debugging the app?

I already found the same issue on here. Restarted iPhone, Mac and visual studio as per the solution on that thread, but that didn't help me.

Best Answers

  • LucasZhangLucasZhang Xamurai
    Accepted Answer

    The newest version of VS for mac is 8.x.x .So you can firstly update the IDE .

  • SreeeeSreeee IN ✭✭✭✭✭
    Accepted Answer

    @LucasZhang I have updated the VS, Mac OS and Xcode to the latest version and the problem solved. Now I am able to run on real iPhone devices.

Answers

  • LucasZhangLucasZhang Member, Xamarin Team Xamurai
    Accepted Answer

    The newest version of VS for mac is 8.x.x .So you can firstly update the IDE .

  • SreeeeSreeee INMember ✭✭✭✭✭

    @LucasZhang I checked the latest stable update of VS, latest version showing was 7.7.4.1. Didn't see 8.x.x version.

  • LucasZhangLucasZhang Member, Xamarin Team Xamurai

    VS for mac 2019 .

  • SreeeeSreeee INMember ✭✭✭✭✭

    @LucasZhang I am using VS Community 2017 for Mac

  • LucasZhangLucasZhang Member, Xamarin Team Xamurai

    You can update it to 2019 .

  • SreeeeSreeee INMember ✭✭✭✭✭

    @LucasZhang Any way to solve this issue in 2017?

  • LucasZhangLucasZhang Member, Xamarin Team Xamurai

    I think it is the best way .

  • SreeeeSreeee INMember ✭✭✭✭✭

    @LucasZhang I will try and update here.

  • SreeeeSreeee INMember ✭✭✭✭✭

    @LucasZhang Update

    Updated the VS to 2019. But Xcode 10.2 is required for working on VS 2019 and my current version of Xcode is 10.1. For installing Xcode 10.2 it requires Mac OS X 10.14.3 or later. But my current Mac OS version is 10.13.6. For updating Mac I need permission from top. Waiting for permission.

  • SreeeeSreeee INMember ✭✭✭✭✭
    Accepted Answer

    @LucasZhang I have updated the VS, Mac OS and Xcode to the latest version and the problem solved. Now I am able to run on real iPhone devices.

  • surbhidhingrasurbhidhingra Member

    My Xcode is 10.3 and VS is 2019, but still facing this issue, unable to run on real iphones

  • 15mgm1515mgm15 USMember ✭✭✭✭

    @surbhidhingra Did you figured this out?

  • SreeeeSreeee INMember ✭✭✭✭✭

    @15mgm15 Yes, I have updated the VS, Mac OS and Xcode to the latest version and the problem solved. Now I am able to run on real iPhone devices.

Sign In or Register to comment.