Missing 120x120 While Uploading To Asset Store.

SehlorSehlor Member ✭✭

Hello All, Using Visual Studio Community 2019 for Mac and trying to build my Xamarin Forms app for App Store,

Build and Runs pretty fine BUT, it gives me this error while i try to upload to App Store,

ERROR: ERROR ITMS-90022: "Missing required icon file. The bundle does not contain an app icon for iPhone / iPod Touch of exactly '120x120' pixels, in .png format for iOS versions >= 7.0."

I tried every single solution with this google search: Xamarin iOS ITMS-90022 site: forums . xamarin[dot]com

I Tried naming all my Icons according to Apple Developer Docs here: developer[dot]apple[dot]com/library/archive/qa/qa1686/_index.html

But Visual Studio converts naming to [email protected] when i check the resulting ipa file.

Can someone please point me to right direction because honestly, it is driving me mad.

Thank you.

Answers

  • SebastianSeidel.9226SebastianSeidel.9226 DEInsider, University ✭✭✭✭

    Have a look at the iOS-project in your Xamarin.Forms solution. There is a Resources-folder that contains an Images.xcassets file. Double click that file will open the file. On the left side you see all the contained items like AppIcons. If you select AppIcons all the provided icons are shown. Check that all the required ones are set.

  • SehlorSehlor Member ✭✭

    All the required Icons are set Sebastian, thank you.

  • SehlorSehlor Member ✭✭

    I am using Visual Studio no XCode and Asset Bundles, this answer is for old Icon files ( Not Asset Bundle Ones ) But thank you for the answer.

  • Cansado2930Cansado2930 ESMember ✭✭

    Delete assets and create a new asset, and then it works. if you update from asset by default when create app, it fails

  • SehlorSehlor Member ✭✭

    @Cansado2930 said:
    Delete assets and create a new asset, and then it works. if you update from asset by default when create app, it fails

    Tried this countless times, renamed everything but no luck...

  • Cansado2930Cansado2930 ESMember ✭✭

    :( Yesterday I have the same problem that you when I built IPA on Windows with the last version of VS2019 Community, Apple store reject it by 4 icons between them the 120x120. And when I did it, worked and store accept the IPA. Other thing that you can try, On assets, create assets and assets1, both with all icons and select on the manifest the asset1 (the second that you have created. And check if you have updated VS2019

  • SehlorSehlor Member ✭✭

    @Cansado2930 said:
    :( Yesterday I have the same problem that you when I built IPA on Windows with the last version of VS2019 Community, Apple store reject it by 4 icons between them the 120x120. And when I did it, worked and store accept the IPA. Other thing that you can try, On assets, create assets and assets1, both with all icons and select on the manifest the asset1 (the second that you have created. And check if you have updated VS2019

    I am gonna try this and get back to you.

Sign In or Register to comment.