Forum Visual Studio

Can no longer debug on iOS device after update to Visual Studio 2019 & latest Visual Studio for Mac

DerekMasseyDerekMassey CAMember ✭✭


Last week I was able to compile and run my iOS app using Visual Studio 2017 paired with a MacBook with Visual Studio for Mac.

After the last Visual Studio for Mac update, the mac was updated to Xamarin.iOS 12.8 so I was forced to update to Visual Studio 2019 version 16.0.4.
Now when I try to run my iOS application it seems to build properly but then it says.

========== Build: 2 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
========== Deploy: 0 succeeded, 0 failed, 0 skipped ==========

I've tried rebooting all of the windows/mac/iOS.
Tried doing a clean.

Also if I right click on my project in the solution explorer and press deploy then it gets a little further.
you get "CopyingFile - PercentComplete: 17%" etc (it takes forever)

eventually the build update says "Application bundle 'com.myapp.testapp' installed on 'My iPhone'"

Is does deploy, but the app never starts. I can run it manually but there is no way to debug.

So my questions are.
1. When I press run in visual studio why does it say deploy failed, but then if I right click on the project to deploy it, then it actually deploys.
2. Why doesn't it run after deploying. There are no error messages

So frustrating, this all worked last week.


  • DerekMasseyDerekMassey CAMember ✭✭

    Finally made some progress. in the iOS project properties --> iOS Debug --> Unchecked Debug over wifi.
    My project actually runs again.
    Stopped the project, turned "Debug Over Wifi" back on and it still seems to work.

Sign In or Register to comment.