iOS app icons missing (says application loader)

walliwalli Member ✭✭

Hello,
when uploading an ipa file with the application loader, it stop half way through and says some icon sizes are missing in my asset catalog (specifically: 120, 76, 167, 152).
However, icon set in the asset catalog has all the necessary images for iOS publishing. What am I doing wrong? We solved this issue earlier by removing the whole catalog and creating a new one. This does not seem to work anymore.
Regards,
Gabriel

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    This error means you haven't set all the required icons with the correct format.
    Try to fill all the listed icons in the AppIcon asset:

  • walliwalli Member ✭✭

    @LandLu

    icon set in the asset catalog has all the necessary images for iOS publishing.

    I'm unfortunatly not allowed to post hyperlinks ...

    us.v-cdn.net/5019960/uploads/editor/4k/7yiiet59ehuu.png

    also Contents.json:

    {
    "images": [
    {
    "filename": "40.png",
    "size": "20x20",
    "scale": "2x",
    "idiom": "iphone"
    },
    {
    "filename": "60.png",
    "size": "20x20",
    "scale": "3x",
    "idiom": "iphone"
    },
    {
    "filename": "58.png",
    "size": "29x29",
    "scale": "2x",
    "idiom": "iphone"
    },
    {
    "filename": "87.png",
    "size": "29x29",
    "scale": "3x",
    "idiom": "iphone"
    },
    {
    "filename": "80.png",
    "size": "40x40",
    "scale": "2x",
    "idiom": "iphone"
    },
    {
    "filename": "120.png",
    "size": "40x40",
    "scale": "3x",
    "idiom": "iphone"
    },
    {
    "filename": "120-1.png",
    "size": "60x60",
    "scale": "2x",
    "idiom": "iphone"
    },
    {
    "filename": "180.png",
    "size": "60x60",
    "scale": "3x",
    "idiom": "iphone"
    },
    {
    "filename": "20.png",
    "size": "20x20",
    "scale": "1x",
    "idiom": "ipad"
    },
    {
    "filename": "40-1.png",
    "size": "20x20",
    "scale": "2x",
    "idiom": "ipad"
    },
    {
    "filename": "29.png",
    "size": "29x29",
    "scale": "1x",
    "idiom": "ipad"
    },
    {
    "filename": "58-1.png",
    "size": "29x29",
    "scale": "2x",
    "idiom": "ipad"
    },
    {
    "filename": "40-2.png",
    "size": "40x40",
    "scale": "1x",
    "idiom": "ipad"
    },
    {
    "filename": "80-1.png",
    "size": "40x40",
    "scale": "2x",
    "idiom": "ipad"
    },
    {
    "filename": "167.png",
    "size": "83.5x83.5",
    "scale": "2x",
    "idiom": "ipad"
    },
    {
    "filename": "76.png",
    "size": "76x76",
    "scale": "1x",
    "idiom": "ipad"
    },
    {
    "filename": "152.png",
    "size": "76x76",
    "scale": "2x",
    "idiom": "ipad"
    },
    {
    "filename": "1024.png",
    "size": "1024x1024",
    "scale": "1x",
    "idiom": "ios-marketing"
    },
    {
    "size": "60x60",
    "scale": "2x",
    "idiom": "car"
    },
    {
    "size": "60x60",
    "scale": "3x",
    "idiom": "car"
    },
    {
    "role": "notificationCenter",
    "size": "24x24",
    "subtype": "38mm",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "role": "notificationCenter",
    "size": "27.5x27.5",
    "subtype": "42mm",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "role": "companionSettings",
    "size": "29x29",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "role": "companionSettings",
    "size": "29x29",
    "scale": "3x",
    "idiom": "watch"
    },
    {
    "role": "appLauncher",
    "size": "40x40",
    "subtype": "38mm",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "role": "appLauncher",
    "size": "44x44",
    "subtype": "40mm",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "role": "appLauncher",
    "size": "50x50",
    "subtype": "44mm",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "role": "quickLook",
    "size": "86x86",
    "subtype": "38mm",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "role": "quickLook",
    "size": "98x98",
    "subtype": "42mm",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "role": "quickLook",
    "size": "108x108",
    "subtype": "44mm",
    "scale": "2x",
    "idiom": "watch"
    },
    {
    "size": "1024x1024",
    "scale": "1x",
    "idiom": "watch-marketing"
    },
    {
    "size": "16x16",
    "scale": "1x",
    "idiom": "mac"
    },
    {
    "size": "16x16",
    "scale": "2x",
    "idiom": "mac"
    },
    {
    "size": "32x32",
    "scale": "1x",
    "idiom": "mac"
    },
    {
    "size": "32x32",
    "scale": "2x",
    "idiom": "mac"
    },
    {
    "size": "128x128",
    "scale": "1x",
    "idiom": "mac"
    },
    {
    "size": "128x128",
    "scale": "2x",
    "idiom": "mac"
    },
    {
    "size": "256x256",
    "scale": "1x",
    "idiom": "mac"
    },
    {
    "size": "256x256",
    "scale": "2x",
    "idiom": "mac"
    },
    {
    "size": "512x512",
    "scale": "1x",
    "idiom": "mac"
    },
    {
    "size": "512x512",
    "scale": "2x",
    "idiom": "mac"
    }
    ],
    "info": {
    "version": 1,
    "author": "xcode"
    }
    }

    us.v-cdn.net/5019960/uploads/editor/5h/0122cfuo3jtj.png

    Theoretically, nothing should be missing...

  • LandLuLandLu Member, Xamarin Team Xamurai

    It seems you have uploaded all the icons required. Please check your icon's format, it shouldn't contain a transparent mask.
    Read this guideline for more information about the icon of iOS: https://developer.apple.com/design/human-interface-guidelines/ios/icons-and-images/app-icon/.
    Moreover, the application loader will tell you which icon image not fitting the requirement. Please change that error image source to a formatted one.

  • walliwalli Member ✭✭

    We managed push our app into the app store by complete creating a new asset catalog.
    However, we now want to upload a hotfix and are stuck at the exact same error message (nothing has changed inside the assets).

  • LandLuLandLu Member, Xamarin Team Xamurai

    Please check the value of XSAppIconAssets in your info.plist.
    Is it set to the correct path of your asset catalog in your project?
    Here is my info.plist:

    <key>XSAppIconAssets</key>
    <string>Assets.xcassets/AppIcon.appiconset</string>
    

    And my files are placed under that folder. Root => Assets.xcassets => AppIcon.appiconset

  • walliwalli Member ✭✭

    The files are located correctly, as is the path in info.plist :


    What else can we do? We need to release a new version to the app store.
    Regards
    Gabriel

  • BrianConradBrianConrad USMember ✭✭✭

    I saw this problem yesterday when I was updating my iOS app. Seems that the project had turned off the Include In Project for the xcassets. Including it solved the problem for the iPad version. But the iPhone version had an old list of icons which made it through before so I just deleted those from the Info.plist and made sure the Asset Catalog was using the proper xcassts.

  • juliagilbertjuliagilbert Member ✭✭

    Use Settings > General > Storage & iCloud Usage > Storage to find the app, tap it, and then you can tap Delete App. (If you sync with iTunes, you can also delete via iTunes.)

Sign In or Register to comment.