Got a SIGABRT while executing native code.

ScidaqScidaq Member ✭✭

Last week I had to update my mac and xcode and iphone to the latest, from that point on all my apps have been failing to build.
XCode is: 10.2
IOS is: 10.14.4
VS is 15:9:3
Xamarin is 4.12.3.73
Xamarin IoS and Xamarin Mac 12.2.1.11
Also deleted mac's cache and bin / obj etc (as usual)
All apps fail and did deploy prior to update get the same or very similar error.
Really appreciate any help. I've only been able to progress in Android

    frame #3: 0x000000010df620fa mlaunch`mono_threads_summarize(ctx=0x0000700001b9a660, out=<unavailable>, hashes=<unavailable>) at threads.c:5924:3 [opt]
    frame #4: 0x000000010de06ac5 mlaunch`sigterm_signal_handler(_dummy=15, _info=0x0000700001b9ac58, context=0x0000700001b9acc0) at mini-posix.c:232:7 [opt]
    frame #5: 0x00007fff5bb18b5d libsystem_platform.dylib`_sigtramp + 29
    frame #6: 0x00007fff5ba68267 libsystem_kernel.dylib`semaphore_wait_trap + 11
    frame #7: 0x000000010dea8555 mlaunch`finalizer_thread [inlined] mono_os_sem_wait(flags=MONO_SEM_FLAGS_ALERTABLE) at mono-os-semaphore.h:90:8 [opt]
    frame #8: 0x000000010dea854a mlaunch`finalizer_thread at mono-coop-semaphore.h:43 [opt]
    frame #9: 0x000000010dea853e mlaunch`finalizer_thread(unused=<unavailable>) at gc.c:903 [opt]
    frame #10: 0x000000010df624f9 mlaunch`start_wrapper_internal(start_info=<unavailable>, stack_ptr=<unavailable>) at threads.c:1098:3 [opt]
    frame #11: 0x000000010df62357 mlaunch`start_wrapper(data=0x00007fdef7d2fdf0) at threads.c:1158:8 [opt]
    frame #12: 0x00007fff5bb212eb libsystem_pthread.dylib`_pthread_body + 126
    frame #13: 0x00007fff5bb24249 libsystem_pthread.dylib`_pthread_start + 66
    frame #14: 0x00007fff5bb2040d libsystem_pthread.dylib`thread_start + 13

(lldb) detach

Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries

used by your application.

Process 87978 detached
(lldb) quit

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    If you have updated your Visual Studio for Mac to the latest, you should also update your VS for Windows to match the pairing.
    As the latest Visual Studio for Mac is using Xamarin.iOS 12.8, you have to install Visual Studio 2019 on your Windows.
    And I'm a little confused about your iOS version. You said you have updated the iOS too, but the latest iOS version is 12.2.
    You have to keep all the related tools using the same version then test a blank project to see the result.

  • ScidaqScidaq Member ✭✭

    Thanks LandLu
    Looks like you're right, I'm taking the plunge to 2019, Seems very soon after its release - I'll let you know.
    The Versions were simply taken form the current 'Help About' on relative apps.

Sign In or Register to comment.