Editor not sizing properly

NielsCupNielsCup NLMember ✭✭✭
edited April 17 in Xamarin.Forms

I would like the Editor to autoSize and display the whole text. What happens now is when I display a large text in the editor (Lorem Ipsum....) the editor displays only 1 or 1 and a half line and I have to scroll inside the Editor. When I start editing and add a newline/enter, the Editor size jumps to the correct size displaying the whole text.

For iOS I have also tried creating a customRenderer (iOS) setting Control.ScrollEnabled = false; and Control.SizeToFit(); and that seems to work the first time but after editing a while, the Editor size jumps back to 1 line. tapping return on the keyboard the editor jumps back to full size. The AutoSize property does not seem do much either.

On Android it is a different story: the text is visible but it doesn't fit in the editor entirely, I have a feeling that the Editor height is calculated by multiplying the number if linbreaks, which results in the text never fitting the control because it does not wrap text.

Does anybody know how to solve this issue?

@Microsoft PS: I am unable to post a question in Chrome (on Mac) anymore? Buttons don't get disabled and the "Category does not exist message" does not display. It does work in Safari.

Tagged:

Answers

  • ClintStLaurentClintStLaurent USUniversity ✭✭✭✭✭

    @NielsCup said:
    I would like the Editor to autoSize and display the whole text. What happens now is when I display a large text in the editor (Lorem Ipsum....) the editor displays only 1 or 1 and a half line and I have to scroll inside the Editor. When I start editing and add a newline/enter, the Editor size jumps to the correct size displaying the whole text.

    Can we see your XAML? It should just be a matter of setting the control and its containing Grid to FillAndExpand

    @Microsoft PS: I am unable to post a question in Chrome (on Mac) anymore? Buttons don't get disabled and the "Category does not exist message" does not display. It does work in Safari.

    FYI: I have the same issue on Firefox in Windows. I thought it was just an issue with new networking proxies and firewalls at my work. But now that I hear this I wonder if it is something site related. My workaround in Windows is having to right-click/copy a link from email and paste into Chrome. Its annoying to be able to use one browser for everything else - and then one just for the Forum.

  • NielsCupNielsCup NLMember ✭✭✭

    @ClintStLaurent Thanks for you reply! We don't use XAML but you may have pointed me in the right direction, I will have a look.

    FYI: I have the same issue on Firefox in Windows. I thought it was just an issue with new networking proxies and firewalls at my work.

    I had the same issue when I worked from home yesterday, today the same issue so I decided to try another browser, copy pasting my question and all and I saw a few validation messages that I didn't see in Chrome...

Sign In or Register to comment.