Forum General

XS beta 4 MacOSX referencing Solutions from Solution cannot load projects

moljacmoljac HRBeta ✭✭✭

When opening existing solution where project were added through referencing other
sln file in VS projects cannot be loaded anymore.

Error is Load Failed.
Could not find part of path ....

After Reload the error is unknown file format.

Adding projects separately one by one works.

Now side-by-side installation of MonoDevelop is affected by this too...

On windows XS loads project w/o hassle.

MacOSX installation:

  • Mountain lion
  • case insensitive

Best Answer


  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    Can you please provide the Xamarin Studio log files?

  • moljacmoljac HRBeta ✭✭✭

    Sorry Jon it was long past midnight and I was too tired.

    I took a short peek into log files on Windows and tried to compare, but nothing too suspicious.
    SDK path was found, NDK not (not required right). Only suspicious is in components log is faling to load MonoAnroid entitlements.

    Here are Windows Logs. MacOSX in another thread.

    thanks + regards

  • moljacmoljac HRBeta ✭✭✭

    MACOSX logs

    It seems something in SlnFileFormat.LoadSolution...

    Projects from solution that cannot be accessed are on github MonoMobile.Dialog

    In few minutes I'll post steps with smallest reproducible test case

  • moljacmoljac HRBeta ✭✭✭

    Jon wait for a minute.
    On anoter Mac it is OK.
    We are checking paths and everything.

    It seems that checkout location was wrong, so relative paths were messed up.

    Will be back in a minute or two

  • moljacmoljac HRBeta ✭✭✭
    • Created folder structure that resembles structure on our projects

      • references\git\
        git repos
        references\git\MonoMobile.Dialog clone from git
        references\git\MonoMobile.Dialog\MonoMobile.Dialog.sln referenced solution!

      • projects\XamarinStudioTests\SolutionReferencingSolutions

    • In VS created new soution SolutionReferencingSolutions.sln

    • In VS added Solution Folder MonoMobile.Dialog

      • Add existing project (change type to sln) +/ navigate to MonoMobile.Dialog.sln +/ Open
    • Optional: added folder where on Windows MT dlls are so everything can be compiled

    • XSb4[Windows] open solution

      • Expected errors:
        • Windows Phone
        • MonoTouch (?!!? why not loading on Windows?!?!)
          Unknown Solution type {};{} Guids for MT
    • Moved to MacOSX

      • Loaded as expected
    • On my way to see what has happened - suspecting SVN checkout problems

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    I'm confused as to what the error is. This may be a bug; could you please create a full repro and file a bug at

    MonoTouch (?!!? why not loading on Windows?!?!)

    This is expected: MonoTouch projects cannot be opened from Xamarin Studio on Windows, only from Visual Studio.

  • moljacmoljac HRBeta ✭✭✭

    Completely new checkout solved the issue.

    I'll try to test with small Test Solution I did earlier today, but got dragged away by tasks.

    Is there a reason to disallow working with MT projects in MD and XS?

    BTW. I got 3 mails that You have answered my question but only with link to thread and "Have a nice day" and this is You signature, right? No content.

Sign In or Register to comment.