How to pass multiple values from one activity to another activity?

2»

Answers

  • jezhjezh Member, Xamarin Team Xamurai

    Yes, you are right . Have a good time to achieve your app.

    And could you mark the solution as a answer?

  • sreedhar_msdaxsreedhar_msdax Member ✭✭✭

    Hi Jezh,

    I have seen the link which you shared regarding barcode scanning but all suggestions referring to Xamarin.Form some assemblies are not working when using the same code and no suggestion I got for Xamarin.Android bar code scanning I am able to scan item but its not storing value empty display it is showing...

    How can I achieve this?

  • jezhjezh Member, Xamarin Team Xamurai

    Your code can scan the barcode, but it can't show the result of scanning?
    Could you please share a basic demo?

  • sreedhar_msdaxsreedhar_msdax Member ✭✭✭

    Hi Jezh,

    on deploying project I am getting this error:

    Severity Code Description Project File Line Suppression State
    Error ADB0000: Deployment failed
    Mono.AndroidTools.AdbException: closed
    at Mono.AndroidTools.Util.AggregateAsyncResult.CheckError(CancellationToken token) in E:\A_work\1824\s\External\androidtools\Mono.AndroidTools\Util\AggregateAsyncResult.cs:line 72
    at Mono.AndroidTools.Adb.AdbClient.EndWriteCommandWithStatus(IAsyncResult asyncResult) in E:\A_work\1824\s\External\androidtools\Mono.AndroidTools\Adb\AdbClient.cs:line 328
    at System.Threading.Tasks.TaskFactory1.FromAsyncCoreLogic(IAsyncResult iar, Func2 endFunction, Action1 endAction, Task1 promise, Boolean requiresSynchronization) 0

    can you please suggest how to resolve

  • sreedhar_msdaxsreedhar_msdax Member ✭✭✭

    Hi Jezh, I am getting this error while deploying

    1>Starting deployment to Android_Accelerated_x86_Oreo ...
    1>Starting emulator Android_Accelerated_x86_Oreo ...
    1>C:\Program Files (x86)\Android\android-sdk\emulator\emulator.EXE -partition-size 512 -no-boot-anim -no-accel -avd Android_Accelerated_x86_Oreo -prop monodroid.avdname=Android_Accelerated_x86_Oreo
    1>emulator: WARNING: x86 emulation may not work without hardware acceleration!
    1>Emulator Android_Accelerated_x86_Oreo is running.
    1>Waiting for emulator to be ready...
    ========== Build: 0 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

    Please suggest how to resolve

  • sreedhar_msdaxsreedhar_msdax Member ✭✭✭

    Hi Jezh,

    Previous problem resolved while deploying but now is raising a new error with different codes sometimes below I have copied error s please check and suggest how to resolve

    Error 1:

    Severity Code Description Project File Line Suppression State
    Error ADB0000: Deployment failed
    Mono.AndroidTools.AdbException: device 'emulator-5554' not found
    at Mono.AndroidTools.Util.AggregateAsyncResult.CheckError(CancellationToken token) in E:\A_work\1824\s\External\androidtools\Mono.AndroidTools\Util\AggregateAsyncResult.cs:line 72
    at Mono.AndroidTools.Adb.AdbClient.EndConnectTransport(IAsyncResult asyncResult) in E:\A_work\1824\s\External\androidtools\Mono.AndroidTools\Adb\AdbClient.cs:line 207
    at System.Threading.Tasks.TaskFactory1.FromAsyncCoreLogic(IAsyncResult iar, Func2 endFunction, Action1 endAction, Task1 promise, Boolean requiresSynchronization) 0

    Error 2:

    Severity Code Description Project File Line Suppression State
    Error ADB0000: device 'emulator-5554' not found
    at Mono.AndroidTools.Util.AggregateAsyncResult.CheckError(CancellationToken token) in E:\A_work\1824\s\External\androidtools\Mono.AndroidTools\Util\AggregateAsyncResult.cs:line 72
    at Mono.AndroidTools.Adb.AdbClient.EndConnectTransport(IAsyncResult asyncResult) in E:\A_work\1824\s\External\androidtools\Mono.AndroidTools\Adb\AdbClient.cs:line 207
    at System.Threading.Tasks.TaskFactory1.FromAsyncCoreLogic(IAsyncResult iar, Func2 endFunction, Action1 endAction, Task1 promise, Boolean requiresSynchronization) 0

  • sreedhar_msdaxsreedhar_msdax Member ✭✭✭

    Hi Jezh,

    After deploying application when I am r=trying to open app in emulator the below error I am getting how to resolve this

  • jezhjezh Member, Xamarin Team Xamurai

    You can try uninstalling the app and reinstalling it.

  • sreedhar_msdaxsreedhar_msdax Member ✭✭✭

    Hi Jezh,
    I even tried this but no luck still same error

  • jezhjezh Member, Xamarin Team Xamurai

    Could you please post the full errors about this question?

  • sreedhar_msdaxsreedhar_msdax Member ✭✭✭

    I didn't get any error. project build is successful and deploy is success but in emulator app giving the above mentioned error...

  • jezhjezh Member, Xamarin Team Xamurai

    Generally, we will see the latest thread first. So why not create a new thread when you have a new question?

Sign In or Register to comment.