MT3001 Could not AOT the assembly

AndrewHodderAndrewHodder USMember

Up until a week or two ago, our iOS project built successfully, however this week we can't get the project to build for a connected device. When building for the simulator, it works as expected. The project does not build for connected devices either debug or release modes. Did something change for iOS builds that we are not adhering to?

The build logs show that MTOUCH failed with the following:

MTOUCH : error MT3001: Could not AOT the assembly '/{PATH_TO_PROJECT}/{PROJECT_NAME}/src/{PROJECT_NAME}.iOS/obj/iPhone/Release/mtouch-cache/3-Build/{PROJECT_NAME}.dll'
at Xamarin.Bundler.AOTTask.ExecuteAsync () [0x00232] in /Users/builder/jenkins/workspace/xamarin-macios/xamarin-macios/tools/mtouch/BuildTasks.mtouch.cs:256
at Xamarin.Bundler.BuildTask.Execute (Xamarin.Bundler.BuildTasks build_tasks) [0x00368] in /Users/builder/jenkins/workspace/xamarin-macios/xamarin-macios/tools/common/BuildTasks.cs:258
at Xamarin.Bundler.BuildTask.Execute (Xamarin.Bundler.BuildTasks build_tasks) [0x00368] in /Users/builder/jenkins/workspace/xamarin-macios/xamarin-macios/tools/common/BuildTasks.cs:258
at Xamarin.Bundler.BuildTask.Execute (Xamarin.Bundler.BuildTasks build_tasks) [0x00368] in /Users/builder/jenkins/workspace/xamarin-macios/xamarin-macios/tools/common/BuildTasks.cs:258
at Xamarin.Bundler.BuildTasks+<>c__DisplayClass4_0.b__0 () [0x0002e] in /Users/builder/jenkins/workspace/xamarin-macios/xamarin-macios/tools/common/BuildTasks.cs:49
The command exited with code 1.

Sign In or Register to comment.