Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

New single page app crashes with iOS simulator 8 & 9

DavidJadeDavidJade USBeta ✭✭

I can't even run a newly generated single page app in the simulator for iOS 8.4 or iOS 9.3. I have add no code at all to the newly generated app. I generated on VS for Mac (but I've also tried on VS 2017 on Windows). I get a white screen and then the app crashes before the Main entry point. Totally bombs out of the debugger so I can't even see what is crashing. No error msgs or anything - just terminates and disappears. I have tried many different simulator configurations (iPads, iPhones, etc....).

This default/generated single page add however does run on a real iOS 9.3 iPad - it's just the simulator that isn't working. I can also generate new empty XCode apps and they run just fine on the same simulator image for 8 or 9.

This makes it rather hard to continue to develop an app that we want to support as many iOS versions back as possible as our market unfortunately, is one where people hang onto older devices for quite a while.

Any ideas on how I can at least figure out where in the Xamarin frameworks that app is crashing? Or what I can do next to resolve this and move the project forward?

thanks

Answers

  • ColeXColeX Member, Xamarin Team Xamurai
    edited March 2019

    Could provide us your full build logs for iOS simulator? (please add -v -v -v -v to additional mtouch args inside your project settings > iOS build)

Sign In or Register to comment.