Base.apk code is missing when deploying Visual Studio 2017 Xamarin.Android app to live device

WillGWillG Member ✭✭

Hi All,
New Xamarin developer here. I am trying to deploy an empty Xamarin.Android device to my Motorola 7.1.1 device and I'm getting the following error message from Visual Studio:

Severity Code Description Project File Line Suppression State
Error ADB0010: Failure [INSTALL_FAILED_INVALID_APK: Package couldn't be installed in /data/app/App1.App1-1: Package /data/app/App1.App1-1/base.apk code is missing]
at Mono.AndroidTools.Internal.AdbOutputParsing.CheckInstallSuccess(String output, String packageName)
at Mono.AndroidTools.AndroidDevice.<>c__DisplayClass95_0.b__0(Task1 t) at System.Threading.Tasks.ContinuationTaskFromResultTask1.InnerInvoke()
at System.Threading.Tasks.Task.Execute() 0

Visual Studio version is 15.9.7
Xamarin is 4.12.3.80
Xamarin.Android SDK is 9.1.7.0

I'm using Shared Runtime, and I've set my phone up in Developer Mode.

Any help or suggestions would be appreciated. I've been at this for a few hours and not much luck.

Thanks, Will

Answers

  • WillGWillG Member ✭✭

    Correction:

    New Xamarin developer here. I am trying to deploy an empty Xamarin.Android app to my Motorola 7.1.1 device

    I also have attached the log file from logcat.

  • JarvanJarvan Member, Xamarin Team Xamurai
    edited March 18

    What architecture do you target ? (x86...)
    Try to "Build" > "Clean Project" or Update the Android SDK and all related components.

Sign In or Register to comment.