package is not compatible with monoandroid

My hard disk is burned and everything went inside it, so I bought one,
my xamarin form app was working without errors but now I'm starting to get these two errors on the new computer and can't solve it for a week
anyone can help me please??
1-
Severity Code Description Project File Line Suppression State
Error NU1202 Package XamlAnimatedGif 1.2.1 is not compatible with monoandroid90 (MonoAndroid,Version=v9.0). Package XamlAnimatedGif 1.2.1 supports:
- net40 (.NETFramework,Version=v4.0)
- net45 (.NETFramework,Version=v4.5)
- portable-win81+wpa81 (.NETPortable,Version=v0.0,Profile=Profile32)
- sl5 (Silverlight,Version=v5.0) App1.Android E:\Myproje 12032019\App12\App1\App1\App1.Android\App1.Android.csproj 1

2-Severity Code Description Project File Line Suppression State
Error NU1202 Package SQLite.Net.Platform.XamarinAndroidN 3.1.1 is not compatible with monoandroid90 (MonoAndroid,Version=v9.0). Package SQLite.Net.Platform.XamarinAndroidN 3.1.1 supports: net (.NETFramework,Version=v0.0) App1.Android E:\Myproje 12032019\App12\App1\App1\App1.Android\App1.Android.csproj 1

Tagged:

Answers

  • JoeMankeJoeManke USMember ✭✭✭✭✭

    I would recommend migrating from SQLite.NET-PCL, which hasn't been updated in years, to sqlite-net-pcl which it was originally forked from and is still maintained.

    As for your GIF library, it looks like it has only ever supported Windows platforms so I don't know why you're trying to use it in an Android project.

  • abdalrhmanabdalrhman Member ✭✭

    @JoeManke said:
    I would recommend migrating from SQLite.NET-PCL, which hasn't been updated in years, to sqlite-net-pcl which it was originally forked from and is still maintained.

    As for your GIF library, it looks like it has only ever supported Windows platforms so I don't know why you're trying to use it in an Android project.

    Thanks for answering
    but i'm already using sqlite-net-pcl
    and GIF library was working on android for two months with me

  • mattwardmattward GBMember Xamurai

    Not sure how those NuGet packages worked before. It looks like the PCL profile used by XamlAnimatedGif is not compatible with Android projects. The SQLite.Net.Platform.XamarinAndroidN is not considered compatible with Android projects when using a recent version of NuGet since the package contains assemblies directly in a lib folder, not specifying any target framework.

    A workaround would be to not use NuGet in the project but download the NuGet packages (.nupkg) extract them and reference the binaries directly. This assumes the binaries work OK with Xamarin.Android.

  • abdalrhmanabdalrhman Member ✭✭

    I solved the problem of XamlAnimatedGif in my project I gave up using Gif :D :|

  • harry_coderharry_coder Member ✭✭

    Hi abdalrhman
    Could you please tell me how you solve the monoandroid90 issues, i'm facing the same issue but it is related to MaterialDesignTheme

  • abdalrhmanabdalrhman Member ✭✭
    > @harry_coder said:
    > Hi abdalrhman
    > Could you please tell me how you solve the monoandroid90 issues, i'm facing the same issue but it is related to MaterialDesignTheme
    Hi bro
    I sloved it by Uninstall this bakge XamlAnimatedGif
  • harry_coderharry_coder Member ✭✭

    @abdalrhman Hi bro thanks for reply, could you please tell me the process actually i'm new in xamarin so i have very less knowledge.

  • abdalrhmanabdalrhman Member ✭✭

    @harry_coder said:
    @abdalrhman Hi bro thanks for reply, could you please tell me the process actually i'm new in xamarin so i have very less knowledge.

    Can you write your full issues Here please

  • harry_coderharry_coder Member ✭✭

    I was trying to add MaterialDesignTheme in my project but it is giving the below error
    but it is giving me monoandroid90 error.
    i'm not able to post images here i don't know why !
    can you give me your mail id so i will share images with you.

  • abdalrhmanabdalrhman Member ✭✭

    The best solution is to not use this package(MaterialDesignTheme) in your project

    My email:[email protected]> @harry_coder said:

    I was trying to add MaterialDesignTheme in my project but it is giving the below error
    but it is giving me monoandroid90 error.
    i'm not able to post images here i don't know why !
    can you give me your mail id so i will share images with you.

Sign In or Register to comment.