Push notifications do not work in "production " mode in IOS application

MAG_22MAG_22 Member ✭✭

Hello, good afternoon.
I have the problem that notifications in my IOS app are not getting push notifications in "production" mode.
I'm using the following libraries:
-Xamarin. Firebase. IOS. Analytics 5.5.0
-Xamarin. Firebase. IOS. CloudMessaging 3.1.2
-Xamarin. Firebase. IOS. Core 5.2.0
-Xamarin. Firebase. IOS. InstanceID 3.4.0
If I run the app in "DEBUG " mode, push notifications arrive correctly.
When I upload the app to the AppStore I do with the configuration of APNS in "Production " and the file entitlements. plist also in "Production ".
The compilation form is "AppStore ".
Can someone help me with this problem?
Thanks a lot.
Best regards

Best Answers


  • MAG_22MAG_22 Member ✭✭

    Hello LandLu!
    Thank you very much for the contribution, in a few minutes I try what you have commented and I communicate the results.
    Do You Know Anything if I change the structure to receive notifications of Firebase in IOs?, because Tenfo the last changes of the libraries of firebase and do not work in mode "Production ".
    Thanks a lot.
    Best regards

  • MAG_22MAG_22 Member ✭✭

    Hello LandLu.
    If I have configured the certificates of APNs as you are showing me in the message you sent me.
    But when you try it still does not work, is there any confugarión to do in the files Info. plist and Entitlements. plist?
    Attached an image for you to orient yourself about what I'm talking about.

    Entitlements. plist

    Info. plist

    Thank you so Much for your help.

  • MAG_22MAG_22 Member ✭✭

    To be able to test in "production" mode with Ad-HOC, I need the Ad-Hoc provisioning preset??

  • MAG_22MAG_22 Member ✭✭

    Perfect, now delete the file "Entitlements. plist " and try again.
    I'm warning you that result eh obtained.
    Thanks a lot.

  • Bp007Bp007 Member
    edited March 2019

    Hi, i have some problem, testing with Ad Hoc Works perfect, but when upload it to appstore, the topic suscription does not work.

  • MAG_22MAG_22 Member ✭✭

    Hello, good afternoon.
    I tried to erase things and it doesn't work either.
    Can you upload an App in Ad-Hoc mode, or can It cause some kind of problem?

Sign In or Register to comment.