MsBuild failure after F# android library added

Hello all. There might be a better way to do this, but I'm hoping someone can tell me what I'm doing wrong here.

I have a windows application that uses an F# library for the backend business logic, I heard at the Visual Studio launch that Xamarin supports F# so I downloaded the Xamarin Studio and decide to give it a try. I re-built my application in GTK/Windows and all seemed to work well. I then created an adroid project and hammered out a basic UI. This all compiled and ran without issue, but then I tried adding a reference to the F# library to the Android project and found I couldn't. Trying to find a way that didn't involve having the same code in two separate places. So I added an Android F# Library and linked the needed .FS file from the windows library project.

Now neither the android library or the related android application will build. They deliver the following error message:

Building: Library_Android (Debug)

---------------------- Done ----------------------

Build failed. MSBuild operation failed
Build: 1 error, 0 warnings

I read online that you should deselect the MsBuild engine option, but I don't see that in the project settings.

Any ideas?

Posts

  • VernonBurtVernonBurt USMember

    As an experiment I tried removing the linked file and the library still fails to build - despite being empty. I'm starting to wonder if this is some kind of IDE error.

  • mhutchmhutch USXamarin Team Xamurai

    Could you please check the log files for the full error (Help -> Open Log Directory)?

Sign In or Register to comment.