Xamarin Forms update throws error

JassimRahmaJassimRahma USMember ✭✭✭

Hi,

I am trying to update an Android project in my Xamarin Forms solution but getting below error.

Attempting to resolve dependencies for multiple packages.
Unable to find a version of 'Xamarin.Android.Support.Compat' that is compatible with 'Xamarin.Android.Support.CustomTabs 27.0.2.1 constraint: Xamarin.Android.Support.Compat (= 27.0.2.1)', 'Xamarin.Android.Support.v4 27.0.2.1 constraint: Xamarin.Android.Support.Compat (= 27.0.2.1)'.

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    Have you updated the Xamarin.Forms packages in the Forms project? Try to keep the packages using the same version.

  • JassimRahmaJassimRahma USMember ✭✭✭

    yes updated in the forms project but getting this error when trying to update it in the droid project.

  • PaulNTUPaulNTU USMember ✭✭✭

    I had some issues when updating to the latest forms version and it was to do with the CustomTabs support library

    Follow these steps if you have this problem but backup or checking your solution so that you can roll back if it goes wrong

    1) In Nugget for your solution click on the installed tab and see what version of 'Xamarin.Android.Support.v7.AppCompat' is currently installed to your android project.
    2) Go to the browse tab and search for 'Xamarin.Android.Support.CustomTabs'. Install this to your android project with the same version number that you found in step one
    3) Once installation is complete update the Xamarin forms package to the latest version. It should now be working as it will update all the packages to the required versions

    I hope that helps,
    Paul

  • JassimRahmaJassimRahma USMember ✭✭✭

    They are both on 27.0.2.1 and I am still having the same problem with Xamarin Forms

  • JassimRahmaJassimRahma USMember ✭✭✭

    any luck with this?

Sign In or Register to comment.