Can build to simulator but not device: Can't resolve reference

Error:

MTOUCH: Error MT2101: Can't resolve the reference 'System.Void Xamarin.Forms.Xaml.Internals.SimpleValueTargetProvider::.ctor(System.Object[],System.Object,Xamarin.Forms.Internals.INameScope)', referenced from the method 'System.Void TeenyPlanner.SendDispatchViewAnimating::InitializeComponent()' in 'Xamarin.Forms.Xaml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null'. (MT2101)

There are similar complaints all over the web, no one has a fix.

Some people fix it by upgrading Visual Studio to latest build--and many don't. I don't.

Some people fix it by deleting /bin /obj and /packages files--and many don't. I don't.

Some people fix it by updating NuGet packages--and many don't. I don't.

Please don't suggest any of the above, I've done them several times and they don't work.

Am using Visual Studio Mac, and again, project builds and runs perfectly on iPhone Simulator.

Tagged:

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    What libraries have you used?
    It seems it's the issue of System.Void TeenyPlanner.SendDispatchViewAnimating::InitializeComponent(). Could you find that class in your project?

  • CalmBreathsSlowPulseCalmBreathsSlowPulse Member ✭✭
    edited February 15

    @LandLu, that's good detective work, but I am having the identical problem in a different project with an entirely different structure.

    Trying to track it down, it looks like it has something to do with populating ListViews, because I'm getting the error around ListViews in both places.

    According to this, if I'm reading it correctly: https://forums.xamarin.com/discussion/81228/xamlcompilation-missingmethodexception ...it could be an IDE error in 3.5.0, but I was hoping someone had found a way around it by now.

Sign In or Register to comment.