Can you turn off copying text without a selection?

victoriavictoria SEMember ✭✭✭

For me it's highly annoying that you can copy a line without having text selected. Since cmd+c and cmd+v are so close together, it's very common for me to accidentally hit cmd+c instead of cmd+v since I'm pressing cmd with the left thumb at the same time. This happens to me several times during the day:

I select and cut some code with cmd+x

I move to an empty line and accidentally hit cmd+c instead of cmd+v

...clipboard now consists of "\n" instead

I have to press cmd+z to get my code back, then start all over again.

I get depressed

Answers

  • yousufctecyousufctec USMember ✭✭✭

    @victoria,
    You can disable copying blank line by disabling the following option below.

    Tools > Options > Text Editor > All Languages > 'Apply Cut or Copy Commands to blank lines when there is no selection'

    Regards,
    Yousuf.

Sign In or Register to comment.