Windows 10 entreprise, Visual studio 2017 Pro(15.9.6)+ Xamarin UITest

siewensiewen Member ✭✭

Hello, I am using visual studio 2017 Pro(15.9.6) with Xamarin .UITest (2.2.4), NUnit 2.6.4, NunitAdapter (2.1.1)- As virtual Android, I am using Genymotion Google Nexus 6(api 25). Visual studio 2017 find Genymotion without any problems.
Xamarin.UITest created by default the project TestApp. TestApp can connect to my Android Virutal Genymotion, and start automatically TestApp(no problem for now). I then created some UnitTests, that are in Tests.cs in another project, as explained in the manual of Xamarin.
Now my problem is that when I try to RUN my unitTest via Test Explorer, there is no connection to my Genymotion Android(as well i tried different Android simulators from VS) and get always error: No devices connected.
I also tried to run my Unitest, using the RUN function from VS, but it stop as MainActivity.cs, meaning the TestApp happear on my virtual android, and nothing go forward. I can see that my unitTests are totally ignored.

1 year ago, I had already the same setup and all was working. I think was Visual studio 2015, if i can remember correctly.

Posts

Sign In or Register to comment.