AOT + LLVM - API Level 4

RonanA.7363RonanA.7363 IEMember ✭✭

I'm trying to use AOT + LLVM on my Xamarin.Forms project but I keep getting an error:
Platform library directory for target Arm and API Level 4 was not found. Expected path is "C:\Program Files (x86)\Android\android-sdk\ndk-bundle\platforms\android-4\arch-arm\usr\lib"

The ndk is downloaded and there are loads of platforms in the ndk platforms folder but I can't see how to get it for "android-4".

Can anyone point me in the direction of the ndk platform 4 folder?

Tagged:

Best Answer

Answers

  • RonanA.7363RonanA.7363 IEMember ✭✭

    Once I increased the minimum version of the app to 4.4 it all worked.

    Thanks very much NMackey

  • batmacibatmaci DEMember ✭✭✭✭✭

    was that changed after Xamarin forms 3.0? I remember earlier versions used to support less than api 19 if i am not mistaken.

  • NMackayNMackay GBInsider, University mod

    @batmaci said:
    was that changed after Xamarin forms 3.0? I remember earlier versions used to support less than api 19 if i am not mistaken.

    The minimum was bumped around .NETStandard 2.0 time (as you say, probably 3.0) but to the best of my knowledge, API4 was never supported AFAIK, lowest I even had it working on was API15 I think.

Sign In or Register to comment.