Where can I view console.writeline() ?

I put
Console.WriteLine("\n AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA \n")
into the program's public override bool FinishedLaunching() function, but nothing shows up in the Application Output pad.

Posts

  • DougBellDougBell USMember

    (sorry for being a newbie)
    How do I run my iOS project so that the Console.WriteLine()'s get shown at the MonoDevelop > Application Output?

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    What you send to Console.WriteLine should be printed inside MonoDevelop (or Xamarin.Studio) the Application Output. That's true when running on the iOS simulator or when connected to a device.

    Can you add a breakpoint on the line and step over it using the debugger ? in case the wrong file was edited.

  • DougBellDougBell USMember

    That worked great. Thanks!
    Is the Application Output also logged to a file somewhere?

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    @DougBell Yes, however the Application Output might contain more than what you send to Console.WriteLine.

    Like @cave linked to you can use Console.SetOut to a TextWriter instance, which can be backed by a file. However that file will exists in the device (or simulator) which might not be easy to extract.

    You can also re-use the TcpTextWriter from Touch.Unit to send the output to a socket server (source for one is available in github).

  • alecmcealecmce USMember

    "Application Output" does not exist in my IDE... it's unbelievably infuriating for all the resources online to point to a panel that apparently just didn't make it into my installation... I'm running 4.0.5 (build 4) on Mac OS X. I went to the beta stream in the vague hope that an upgrade would reveal this dark, secret console output panel, but alas :(

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai
    edited May 2013

    @alecmce,

    To enable the window, go to View -> Pads -> Application Output.

    See the attached image. Application Output is at the bottom of the drop down.

  • alecmcealecmce USMember

    Yeah, it's not there.

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    @alecmce, I see. I am using Xamarin Studio 4.0.4 (build 2) from the stable channel.

  • alecmcealecmce USMember

    It wasn't there before I changed to the beta channel either.

  • strangeiocstrangeioc USMember

    I have the same problem as alecmce on one Mac (no Application Output Pad). On a separate Mac I see the pad, but Console.WriteLine("hello world") doesn't seem to output anything to the panel.

    Also tried beta and alpha channels. Two separate, slightly different errors might indicate operator error, but I've spent hours trying to figure this out.

    Both installs are 4.0.13 (stable). The first Mac is OSX 10.7.?. The second is 10.8.5.

    Any thoughts?

  • BrianPAdamsBrianPAdams USMember

    Same boat, no Application Output pad.

  • RackdollRackdoll NLMember

    On Mac OSX,
    Open your own terminal.
    Your Console.WriteLine("blaat"); will log into that window and NOT the application output window.

    Happy Coding! \o

  • JoshGeller.3134JoshGeller.3134 USMember, University

    I had lost my application output because I had added the pad as an item to the debug tab along with Local and Watches. I had to start debugging, pull my Application Tab off the debug tab bar, and now I could see it elsewhere and in the pads menu.

  • GabeWardGabeWard NZMember

    Hi Josh,

    My Application Output has completely disappeared. Where exactly did you go to find the tab again? Any help would be greatly appreciated!

  • NSmithNSmith USMember

    Problems I'm having with Xamarin right now...

    1. Console.WriteLine stopped sending any output to Application Output window
    2. Break points no longer work, it never breaks at any break point.
    3. While single stepping its jumping around the code instead of going line by line while single stepping.

    Is xamarin totally trashed?

  • NSmithNSmith USMember

    Now its even single stepping on commented out code and blank lines

  • JohnHairJohnHair GBMember ✭✭✭✭

    It sounds like your code changes haven't been compiled, try cleaning your solution and build again.

  • NSmithNSmith USMember

    I clean every time i run the program, i dont understand why, it was all working before, single step is now jumping to random lines in the file, even to the middle of a different function or executing comments and ignoring return statements.

  • JohnHairJohnHair GBMember ✭✭✭✭

    How strange, you could delete the bin folders, reboot etc? Definitely sounds like you are running binaries compiled against an older version of your code.

  • DaveHuntDaveHunt USMember ✭✭✭✭✭

    @JohnHair said:
    How strange, you could delete the bin folders, reboot etc? Definitely sounds like you are running binaries compiled against an older version of your code.

    I agree. Try deleting the bin and obj folders.

  • goto Run ==> Run With =>Custom Configuration

Sign In or Register to comment.