Forum Xamarin.Android

Could not determine the installation package com.company.appName

I can't launch my app anymore on Android. The iOS counterpart seems to be fine. The full error is:

ADB0000: Could not determin the installation path for package.com.company.appname. 
'adb shell pm path com.company.appname' returned.

It was working. I pulled some changes from the repo, none of which should have affected any app properties. Actually it was initially launching, but I was getting some odd behavior within the app, so I uninstalled the whole thing off of my phone. Now I cannot launch it at all. What I could find about this error was that my AndroidManifest.xml might have a typo, but I couldn't find anything that stuck out. And like I said, there shouldn't have been any changes in there recently. Any help would be greatly appreciated.

Steps I have already taken: 1. Clean and rebuild 2. restart VS 3. delete obj and bin folders 4. search for solution on here and xamarin forums

Tagged:

Best Answer

Answers

  • alexestralexestr Member ✭✭

    Thanks. Worked perfect.

  • JunedJuned Member ✭✭

    I had a similar problem. I had uninstalled the app from within my Android Phone. I had a Work profile On in my Android phone. Hence Visual Studio Xamarin installed 2 instances of the app on my phone. One for Personal Profile and other for Work Profile. Hence I uninstalled the Work Profile instance of the app manually from my phone, and the deployment succeeded. Work profile can be created using the Island app for running two instances of apps such as Whatsapp.

  • nirav3189nirav3189 Member

    Thanks @YorkGo! that solution saved the day. I also had the same issue on one of the other devices with the work profile where @juned 's solution worked fine. Able to install in both the devices now.

Sign In or Register to comment.