OneSignal error - package does not exist

Hi, I am using a package Com.OneSignal, the required version is 3.1.1 or higher to use OneSignal.Current.IdsAvailable callback function and some others, but I get an error:

  • error: package com.google.android.gms.common.api.GoogleApiClient does not exist

I tried downloading different google packages and cleaning/rebuilding app, but it doesn't seem to work, earlier I didn't use any packages of google, do you have any ideas how to solve this problem?

Best Answer

  • wo997wo997 ✭✭
    Accepted Answer

    @YorkGo said:
    Could you please add a diagnostic build output when this issue happened(As a file attachment or gist link)?

    Problem solved - now I see how dumb I was, I installed OneSignal package only for shared project, it took some time till I realized that something is missing, and during installation of other packages I noticed google.gsm thing so I knew it is related to my problem, finally it's done.

Answers

  • YorkGoYorkGo CNMember, Xamarin Team Xamurai

    Did this error happened you install the Com.OneSignal nuget package? If possible, could you please share the entire error log?

  • wo997wo997 Member ✭✭

    @YorkGo said:
    Did this error happened you install the Com.OneSignal nuget package? If possible, could you please share the entire error log?

    The app could compile when I have been using version 3.0.0, but after upgrading it it keeps displaying 23 critical errors that look almost the same for example:

    • error: package com.google.android.gms.tasks does not exist (always package com.google.android.gms.***)

    I have been installing lots of packages to fix all allerts saying that version of nuget dependencies is wrong except the two probably unrelated to this problem - packages has been restored using NETFramework,Version=v4.6.1 instead of target platform NETStandard,Version=v2.0, but none of them mensions OneSignal or google android packages.

    I have no idea at this point what else I can try

  • YorkGoYorkGo CNMember, Xamarin Team Xamurai

    Could you please add a diagnostic build output when this issue happened(As a file attachment or gist link)?

  • wo997wo997 Member ✭✭

    @YorkGo said:
    Could you please add a diagnostic build output when this issue happened(As a file attachment or gist link)?

    https://drive.google.com/file/d/1d6FfCTNfLjpTw11KWmod0CYCR5DFqEKE/view?usp=sharing
    If you don't solve it don't worry, I am going to use azure push notification servieces, I think it is not worth wasting time on something that might never work.

  • wo997wo997 Member ✭✭
    Accepted Answer

    @YorkGo said:
    Could you please add a diagnostic build output when this issue happened(As a file attachment or gist link)?

    Problem solved - now I see how dumb I was, I installed OneSignal package only for shared project, it took some time till I realized that something is missing, and during installation of other packages I noticed google.gsm thing so I knew it is related to my problem, finally it's done.

  • YorkGoYorkGo CNMember, Xamarin Team Xamurai

    @wo997 , happy coding. :)

Sign In or Register to comment.