Forum Xamarin.Forms
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Editor with Autosize=TextChanges inside scrollview inside grid, not ok on iOS

Make this the content of a normal content page:

<Grid>
   <Grid.RowDefinitions>
      <RowDefinition Height="*"/>
      <RowDefinition Height="200"/> 
   </Grid.RowDefinitions>
   <ScrollView Grid.Row="0">
         <Editor AutoSize="TextChanges"/>
   </ScrollView>
   <Label Grid.Row="1" Text="Random text" VerticalOptions="FillAndExpand" BackgroundColor="Blue"/>
</Grid>

Now, on iOS if you write more then can fit on the screen, the expected behaviour would be for the scroll view to scroll down, so you could Always see what you are typing. This is also how it works on Android. However, on iOS the scrolling doesn't work, so you cant see what you are typing without manually doing the scroll.

Must be a bug, I guess?
Is this a known issue?

Answers

  • JoeMankeJoeManke USMember ✭✭✭✭✭

    The Editor should be internally scrollable. Between AutoSize=TextChanges, being inside a ScrollView, and the ScrollView being in a row with Height=*, I can see a lot of places where the measurement of the Editor is going to get messed up. What is the behavior if you remove the ScrollView and disable AutoSize on the Editor?

  • AndreasBrostenAndreasBrosten USMember ✭✭

    Well, in my real case, I need the editor to be AutoSized. The thing is, I have a page with some content in the top. This top-content can vary in how much space it takes. In the bottom, two buttons should Always be visible (not scrolled).
    Inbetween, I want an Editor-Control. And I can't set this to a constant height, since I don't know how much space is avaliable. And I can't let it just use the rest of the space, since there might not even be any space left, without scrolling.

    So, Yes, the solution with removing the scrollview and removing autosize will work, but won't do the trick for me...

  • RobertEdyveanRobertEdyvean USMember ✭✭

    Still getting this issue on iOS, is this a known issue and is there any solution?

Sign In or Register to comment.