VS2017 15.8.7 build, enterprise, no inspector?

I am stumped... For the life of me I can not find any way to start the inspector.. The button isn't on any toolbar (I opened all of them), and there is no menu option under tools or debug.

I am running Visual Studio 2017 Build 15.8.7, It is an enterprise license, and I have the Mobile .NET workload installed (Xamarin)...

I see it in my options and I have turned it off and on Tools->Options->Xamarin->Other multiple times (with VS restarts between each tick) with no luck as well.

I am at a loss as to where or how to activate it?

(really only need it to ID a few entities while the app is running for use with Xamarin.UITest because they aren't entities in my XAML they are Arc.UserDialogs.) But its stopping me dead in my tracks without it :-(

Answers

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    Hi, sorry to hear about your trouble. What type of app are you trying to inspect (iOS, Android, etc?). If Android, what emulator are you using? https://docs.microsoft.com/en-us/xamarin/tools/inspector/install?tabs=windows#supported-app-platforms might be a good read.

    In addition to the toolbar, you should be able to access the Inspect Current App... menu item from the Tools or Debug menu in Visual Studio.

    Can you also share your Inspector extension log file (%LOCALAPPDATA%\Xamarin\Logs\{VS version}\Inspector {date}.log)? Thank you!

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    And just to be sure, you understand that the app need to be running in debug mode in order to be inspected, yes?

    See https://docs.microsoft.com/en-us/xamarin/tools/inspector/inspect for a little more info.

  • JoshHandelJoshHandel USMember ✭✭

    1) Yes I know I need to be in Debug mode
    2) I have tried both a Image I created that is a Pixel running 8.1 and the VisualStudio_android_23_x86_phone that Visual Studio installed... The images are all supplied by the microsoft repository via the Visual Studio android emulator manager
    3) I have been through those pages about 10 times and no luck finding the issue.
    4) All the log says is "Xamarin.Inspector: Information: 0: Inspector extension loaded" but there is no icon or "Inspect Current App..." in any menu.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    Can you provide the full contents of Visual Studio's Output pane from your debug session?

  • JoshHandelJoshHandel USMember ✭✭

    Here is the Debug Output:
    https://gist.github.com/jhandel/5e61f3785ddb3f3ccd91b5cab6206a6d

    (too big to post)

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    This is very strange, it's behaving as if the Inspector extension is completely disabled, but there's no reason for it to be.

    Your android app project needs to be set as the startup project in your solution. Any chance it's not?

  • JoshHandelJoshHandel USMember ✭✭

    Nope, its the startup project, so that's not it..

    Is it possible there is somewhere else that it could be disabled other than Tools->Options->Xamarin->Other ?

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    Is it possible there is somewhere else that it could be disabled other than Tools->Options->Xamarin->Other ?

    No, it is not.

Sign In or Register to comment.