Problems adding reference to a web service

a_ta_t USMember ✭✭

hi,
i have a xamarin forms v3.0 project with dot net standard v2.0.3 and i am using visual studio 2017 v15.8
the problem is when i adding a web reference to a soap service in the xamarin forms the first problem i encountered was this error

Unable to generate deps.json, it may have been already generated.
You can specify the "-d" option before the tool name for diagnostic output (for example, "dotnet -d ": C:\Program Files\dotnet\sdk\2.1.400\Sdks\Microsoft.NET.Sdk\targets\GenerateDeps\GenerateDeps.proj

i solved it by checking the output directory and permissions like advised here
https://github.com/dotnet/sdk/issues/2128
and here
https://github.com/dotnet/cli/issues/8981

then i encountered anther issue where there was a StackOverFlow error thrown every time i tried to generate the classes for the service

i solved it by unchecking reuse types in referenced assemblies like advised here
https://github.com/dotnet/wcf/issues/2890

after that i encountered anther issue :| when calling any method from the web service i get the following error

System.NotImplementedException: The method or operation is not implemented web service reference

has anyone encountered anything like this ?
is there something i am doing wrong, from what i get from my search there is problems adding WCF services to Xamarin projects
https://github.com/dotnet/wcf/issues/2463

Answers

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭
    I have not been able to add reference to soap ws in XF.

    You can try to add the web reference to android project and use web services in XF using Dependencyservices
Sign In or Register to comment.